Bug 13325 - Default stylesheet needed for braille media
Summary: Default stylesheet needed for braille media
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.w3.org/WAI/GL/WCAG20/WD-WC...
Keywords: InRadar
Depends on: 9454
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-10 16:35 PDT by Nicholas Shanks
Modified: 2013-09-30 11:15 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Shanks 2007-04-10 16:35:40 PDT
With Leopard introducing Grade 2 Contracted Braille throughout the OS, and Safari being an important part of that, WebKit needs to have a default stylesheet specifying which elements do not get contracted (e.g. dt, code, var, etc.)
Since contraction depends on content language, we'd need to fix the language inheritance before WebKit + Braille is usable to anyone.

http://www.w3.org/WAI/GL/WCAG20/WD-WCAG20-TECHS/
http://www.w3.org/WAI/PF/braillecss.html
Comment 1 Alexey Proskuryakov 2007-04-16 12:54:19 PDT
Nick, could you please file a Radar for this? I believe that would help the issue to be properly prioritized.
Comment 2 Mark Rowe (bdash) 2007-04-27 02:59:37 PDT
<rdar://problem/5166144>
Comment 3 James Craig 2013-09-30 11:15:45 PDT
Closing until CSS or PF Working Groups define a braille media type. Otherwise, this is not actionable.