Bug 13319 - Shadows aren't drawn until page redraw
Summary: Shadows aren't drawn until page redraw
Status: RESOLVED DUPLICATE of bug 12729
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://bestbefore.tv/shadows.html
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-10 08:53 PDT by Jonathan del Strother
Modified: 2007-04-30 03:14 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan del Strother 2007-04-10 08:53:49 PDT
If I create a new element with a -webkit-box-shadow css declaration, the shadow isn't drawn until the element behind them is redrawn (eg by resizing that element, or the entire window)


Try going to the link above, and create a few boxes.  None of the new ones should have drop shadows.  Resize the window, and watch the shadows pop into place.

Resizing the boxes doesn't cause the shadow to be drawn, but resizing the element that the shadow appears on (in this case, the page body) does.
Comment 1 Jonathan del Strother 2007-04-30 03:14:31 PDT

*** This bug has been marked as a duplicate of 12729 ***