Bug 133024 - [Phone Number Detection] drop-down menu in the phone number detection box doesn't appear
Summary: [Phone Number Detection] drop-down menu in the phone number detection box doe...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Brent Fulgham
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-05-16 21:17 PDT by Brent Fulgham
Modified: 2014-05-17 14:50 PDT (History)
4 users (show)

See Also:


Attachments
Patch (1.70 KB, patch)
2014-05-16 21:20 PDT, Brent Fulgham
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brent Fulgham 2014-05-16 21:17:49 PDT
The data detector menu was not working because the 'drawRects' function was clearing the set of selected phone numbers on each draw operation. This is wrong, because the drawRect function is called for each drawing tile. Since the screen often has ~9 tiles, and the last tile is likely to not have a phone number causing the set of selected phone numbers to get cleared.
Comment 1 Brent Fulgham 2014-05-16 21:20:11 PDT
Created attachment 231620 [details]
Patch
Comment 2 Brent Fulgham 2014-05-16 21:22:00 PDT
<rdar://problem/16917021>
Comment 3 Sam Weinig 2014-05-16 21:45:19 PDT
Comment on attachment 231620 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=231620&action=review

> Source/WebKit2/ChangeLog:10
> +        time we call drawRect. This gets called ~9 times per screen refresh, so end up with no active

~9 times? That seems like a lot. Do we have a bug tracking why we are calling drawRect here so much?
Comment 4 Brent Fulgham 2014-05-17 00:20:27 PDT
Comment on attachment 231620 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=231620&action=review

>> Source/WebKit2/ChangeLog:10
>> +        time we call drawRect. This gets called ~9 times per screen refresh, so end up with no active
> 
> ~9 times? That seems like a lot. Do we have a bug tracking why we are calling drawRect here so much?

Once per tile. It varies by how much of the screen is dirty, and how large the screen is. I think this is working as designed..
Comment 5 WebKit Commit Bot 2014-05-17 14:50:26 PDT
Comment on attachment 231620 [details]
Patch

Clearing flags on attachment: 231620

Committed r168998: <http://trac.webkit.org/changeset/168998>
Comment 6 WebKit Commit Bot 2014-05-17 14:50:29 PDT
All reviewed patches have been landed.  Closing bug.