Patch forthcoming.
Created attachment 231600 [details] it begins
Comment on attachment 231600 [details] it begins View in context: https://bugs.webkit.org/attachment.cgi?id=231600&action=review > Source/JavaScriptCore/bytecode/StructureSet.h:423 > + void set(uintptr_t pointer, bool singleStructure) Where do we need this version? can we call it something else?
(In reply to comment #2) > (From update of attachment 231600 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=231600&action=review > > > Source/JavaScriptCore/bytecode/StructureSet.h:423 > > + void set(uintptr_t pointer, bool singleStructure) > > Where do we need this version? can we call it something else? It's used by the other set() methods.
Created attachment 231618 [details] it compiles
Created attachment 231622 [details] the patch
Attachment 231622 [details] did not pass style-queue: ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:73: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:74: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:75: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:123: The parameter name "context" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:134: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:135: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:141: The parameter name "list" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 7 in 11 files If any of these errors are false positives, please file a bug against check-webkit-style.
(In reply to comment #6) > Attachment 231622 [details] did not pass style-queue: > > > ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:73: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] > ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:74: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] > ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:75: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] > ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:123: The parameter name "context" adds no information, so it should be removed. [readability/parameter_name] [5] > ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:134: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] > ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:135: The parameter name "structure" adds no information, so it should be removed. [readability/parameter_name] [5] > ERROR: Source/JavaScriptCore/bytecode/StructureSet.h:141: The parameter name "list" adds no information, so it should be removed. [readability/parameter_name] [5] > Total errors found: 7 in 11 files Fixed! > > > If any of these errors are false positives, please file a bug against check-webkit-style.
Landed in http://trac.webkit.org/changeset/169148