Bug 132839 - REGRESSION(r168642): Broke ARM build (Requested by jpfau on #webkit).
Summary: REGRESSION(r168642): Broke ARM build (Requested by jpfau on #webkit).
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Commit Bot
URL:
Keywords:
Depends on:
Blocks: 132772
  Show dependency treegraph
 
Reported: 2014-05-12 15:12 PDT by WebKit Commit Bot
Modified: 2014-05-12 15:21 PDT (History)
3 users (show)

See Also:


Attachments
ROLLOUT of r168642 (18.60 KB, patch)
2014-05-12 15:12 PDT, WebKit Commit Bot
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2014-05-12 15:12:17 PDT
http://trac.webkit.org/changeset/168642 broke the build:
Broke ARM build (Requested by jpfau on #webkit).

This is an automatic bug report generated by webkitbot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests fail.
Comment 1 WebKit Commit Bot 2014-05-12 15:12:45 PDT
Created attachment 231331 [details]
ROLLOUT of r168642

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Vicki Pfau 2014-05-12 15:14:39 PDT
Comment on attachment 231331 [details]
ROLLOUT of r168642

The patch broke the build on ARM, e.g.:

Source/JavaScriptCore/assembler/MacroAssemblerARMv7.h:954:9: error: no matching member function for call to 'loadDouble'
        loadDouble(address.m_ptr, fpTempRegister);

Source/JavaScriptCore/assembler/MacroAssemblerARM64.h:1159:9: error: no matching member function for call to 'loadDouble'
        loadDouble(address.m_ptr, fpTempRegister);

Please try to fix it and have someone who can test the ARM build check it before re-landing.
Comment 3 WebKit Commit Bot 2014-05-12 15:21:45 PDT
Comment on attachment 231331 [details]
ROLLOUT of r168642

Clearing flags on attachment: 231331

Committed r168649: <http://trac.webkit.org/changeset/168649>
Comment 4 WebKit Commit Bot 2014-05-12 15:21:47 PDT
All reviewed patches have been landed.  Closing bug.