Bug 132688 - REGRESSION(r168471): Duplicate builddirs broke master
Summary: REGRESSION(r168471): Duplicate builddirs broke master
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-08 09:55 PDT by Carlos Alberto Lopez Perez
Modified: 2014-05-08 10:51 PDT (History)
4 users (show)

See Also:


Attachments
Patch (2.29 KB, patch)
2014-05-08 10:07 PDT, Carlos Alberto Lopez Perez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Alberto Lopez Perez 2014-05-08 09:55:44 PDT
After landing r168471 the buildmaster broke.

2014-05-08 09:10:17-0700 [-]   Unknown builder 'GTK Linux 64-bit Release' in scheduler 'trunk'
2014-05-08 09:10:17-0700 [-]   Unknown builder 'GTK Linux 64-bit Debug' in scheduler 'trunk'
2014-05-08 09:10:17-0700 [-]   duplicate builder builddir 'gtk-linux-64-release'
2014-05-08 09:10:17-0700 [-]   duplicate builder builddir 'gtk-linux-64-debug'
2014-05-08 09:10:17-0700 [-] Halting master.
2014-05-08 09:10:17-0700 [-] Main loop terminated.
2014-05-08 09:10:17-0700 [-] Server Shut Down.


on r168471 https://bugs.webkit.org/show_bug.cgi?id=131358 I configured the builddir for the tests bots to be the same than the build ones.

This was intentionally, because we (GTK) build a couple of external dependencies with jhbuild and link webkit to them. And the linking process relies on the full path.

But I can workaround it on the buildslaves using symlinks, so is not a problem. I didn't know that the buildmaster will complain about two bots with the same builddir.
Comment 1 Carlos Alberto Lopez Perez 2014-05-08 10:07:11 PDT
Created attachment 231075 [details]
Patch
Comment 2 Carlos Garcia Campos 2014-05-08 10:14:50 PDT
Comment on attachment 231075 [details]
Patch

Ok, let's try again
Comment 3 WebKit Commit Bot 2014-05-08 10:51:11 PDT
Comment on attachment 231075 [details]
Patch

Clearing flags on attachment: 231075

Committed r168475: <http://trac.webkit.org/changeset/168475>
Comment 4 WebKit Commit Bot 2014-05-08 10:51:14 PDT
All reviewed patches have been landed.  Closing bug.