Bug 132651 - [HTML] Default argument to HTMLTableElement.insertRow() should be -1
Summary: [HTML] Default argument to HTMLTableElement.insertRow() should be -1
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
URL: http://www.whatwg.org/specs/web-apps/...
Keywords:
: 138067 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-07 06:46 PDT by Chris Dumez
Modified: 2014-10-27 23:53 PDT (History)
8 users (show)

See Also:


Attachments
Patch (5.39 KB, patch)
2014-05-07 07:28 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2014-05-07 06:46:31 PDT
The default argument to HTMLTableElement.insertRow() should be -1, not 0, according to the specification:
http://www.whatwg.org/specs/web-apps/current-work/multipage/tabular-data.html#htmltableelement

Firefox 29 and IE11 both match the specification. Blink is about to change its behavior as well:
http://code.google.com/p/chromium/issues/detail?id=369803
https://codereview.chromium.org/270213007
Comment 1 Chris Dumez 2014-05-07 07:28:02 PDT
Created attachment 230996 [details]
Patch
Comment 2 WebKit Commit Bot 2014-05-07 10:31:20 PDT
Comment on attachment 230996 [details]
Patch

Clearing flags on attachment: 230996

Committed r168428: <http://trac.webkit.org/changeset/168428>
Comment 3 WebKit Commit Bot 2014-05-07 10:31:25 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 Alexey Proskuryakov 2014-10-27 23:53:26 PDT
*** Bug 138067 has been marked as a duplicate of this bug. ***