Bug 132532 - Nightly builds can't find WebKitLegacy.framework
Summary: Nightly builds can't find WebKitLegacy.framework
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.9
: P2 Critical
Assignee: Nobody
URL:
Keywords:
: 132518 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-03 15:07 PDT by Katsunobu.Oide
Modified: 2015-10-18 11:05 PDT (History)
10 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Katsunobu.Oide 2014-05-03 15:07:20 PDT
Process:         SafariForWebKitDevelopment [64799]
Path:            /Volumes/VOLUME/WebKit.app/Contents/MacOS/WebKit
Identifier:      org.webkit.nightly.WebKit
Version:         ???
Code Type:       X86-64 (Native)
Parent Process:  launchd [324]
Responsible:     SafariForWebKitDevelopment [64799]
User ID:         25008

Date/Time:       2014-05-04 06:58:53.932 +0900
OS Version:      Mac OS X 10.9.2 (13C1021)
Report Version:  11
Anonymous UUID:  C497F6CE-72A7-549A-703D-20174A8F2A34


Crashed Thread:  0

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebKitLegacy.framework/Versions/A/WebKitLegacy
  Referenced from: /Volumes/VOLUME/WebKit.app/Contents/Frameworks/10.9/WebKit.framework/Versions/A/WebKit
  Reason: image not found

Binary Images:
       0x10204e000 -        0x102503ff2  com.apple.JavaScriptCore (538+ - 538.34+) <DDE10A51-91DC-31A9-9550-CE3865931F67> /Volumes/VOLUME/WebKit.app/Contents/Frameworks/10.9/JavaScriptCore.framework/Versions/A/JavaScriptCore
       0x102670000 -        0x102670fff  com.apple.WebKit (r168222 - 538.34+) <2AC270BB-752E-3CE7-A775-CB98FF412AAD> /Volumes/VOLUME/WebKit.app/Contents/Frameworks/10.9/WebKit.framework/Versions/A/WebKit
       0x10267b000 -        0x1028f1ff3  com.apple.WebKit2 (538+ - 538.34+) <F24CDB32-5487-35CB-80B3-97F3EC5CD3D7> /Volumes/VOLUME/WebKit.app/Contents/Frameworks/10.9/WebKit2.framework/Versions/A/WebKit2
       0x102ba6000 -        0x103afcfff  com.apple.WebCore (538+ - 538.34+) <B3CBEF8C-C832-3762-8AD7-33294AA5F99D> /Volumes/VOLUME/WebKit.app/Contents/Frameworks/10.9/WebCore.framework/Versions/A/WebCore
    0x7fff62af6000 -     0x7fff62b29817  dyld (239.4) <2B17750C-ED1B-3060-B64E-21897D08B28B> /usr/lib/dyld
    0x7fff81604000 -     0x7fff81605ffb  libremovefile.dylib (33) <3543F917-928E-3DB2-A2F4-7AB73B4970EF> /usr/lib/system/libremovefile.dylib
Comment 1 Brian Burg 2014-05-04 10:07:21 PDT
*** Bug 132518 has been marked as a duplicate of this bug. ***
Comment 2 Georgij 2014-05-05 02:57:38 PDT
Looks like it is resolved now (r168246)
Comment 3 Alexey Proskuryakov 2014-05-05 09:15:01 PDT
Marking WORKSFORME per the above.