Bug 13229 - Html Editing Tools unavailable on moodle.org
Summary: Html Editing Tools unavailable on moodle.org
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 419.x
Hardware: Macintosh OS X 10.4
: P2 Critical
Assignee: Nobody
URL: http://moodle.org
Keywords:
: 21117 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-30 02:37 PDT by dale
Modified: 2011-02-16 10:49 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dale 2007-03-30 02:37:08 PDT
When attempting to load the HTML content editing tools for the Moodle Online Education System all editing tools do not show up. They display correcting in Moz browsers and Internet Explorer. This renders Safari un useable as an editing (teaching) browser.
Comment 1 David Kilzer (:ddkilzer) 2007-03-30 08:09:43 PDT
Hi Dale, thanks for the bug report!  Which part of Moodle doesn't use an HTML editor? Is it just the issue tracker (which looks like Jira), or is it other pages?  Is the site using Confluence for content, or something else?

http://www.atlassian.com/software/jira/
http://www.atlassian.com/software/confluence/

Steps to get to pages with HTML editors would be VERY helpful!  Just list the links to click on, or if you can open specific pages once you're logged in, just list the URLs.

We need to know which HTML editors they're using before we know whether they will work with Safari or not.  Thanks!

Comment 2 dale 2007-03-31 17:36:06 PDT
Hi,

I'm not sure what editor they use.

But to see where content is edited:
*http://demo.moodle.org/
*Log in as a teacher using the supplied log/pass
*Click the "Moodle Features Demo" link - http://demo.moodle.org/course/view.php?id=4
*Top right of this page is a button "Turn Editing On", click that
*Under the "Topic Outline" center content area for the new page is a small writing hand icon, click that.
*This should take you to the html editing area. It should have a range of tools for editing the text etc. However, it does not. 

I'm not sure if this is a moodle issue or a Safari issue. Apparently on the moodle roadmap is to include the tinyMCE editor, which works OK with Safari.

If you cant access this moodle demo site, contact me and I'll give you instructions to get into my teaching sites.
Comment 3 Alexey Proskuryakov 2007-07-06 07:01:26 PDT
This site uses discontinued htmlArea v3.0 editor <http://www.dynarch.com/projects/htmlarea/>. It doesn't try to load the toolbar for Safari, so it seems that we can only wait for them to switch to TinyMCE.
Comment 4 David Kilzer (:ddkilzer) 2007-07-07 13:26:45 PDT
Switching to an evangelism bug.

Comment 5 Cristian Alvarado 2007-08-06 09:34:53 PDT
(In reply to comment #4)
> Switching to an evangelism bug.
> 
This has been reported on their bug tracker. Unfortunately, a lot of their people use IE and Firefox, so I have no idea when this is planned to be fixed.

http://tracker.moodle.org/browse/MDL-3084

Comment 6 Juan Falgueras 2008-04-02 06:03:03 PDT
(In reply to comment #5)
> (In reply to comment #4)
> > Switching to an evangelism bug.
> > 
> This has been reported on their bug tracker. Unfortunately, a lot of their
> people use IE and Firefox, so I have no idea when this is planned to be fixed.
> 
> http://tracker.moodle.org/browse/MDL-3084
> 


But this is not absolutely true.  If you download the HTMLArea free source code
(In reply to comment #3)
> This site uses discontinued htmlArea v3.0 editor
> <http://www.dynarch.com/projects/htmlarea/>. It doesn't try to load the toolbar
> for Safari, so it seems that we can only wait for them to switch to TinyMCE.
> 
(In reply to comment #3)
> This site uses discontinued htmlArea v3.0 editor
> <http://www.dynarch.com/projects/htmlarea/>. It doesn't try to load the toolbar
> for Safari, so it seems that we can only wait for them to switch to TinyMCE.
> 


But this is not absolutely true.  If you download the (discontinued) source code for HTMLArea (http://www.dynarch.com/projects/htmlarea/HTMLArea-3.0-last-20071025.zip)  You can test it directly with Safari and IT RUNS LIKE A CHARM, except that it adverts you at start that:

"Mozilla < 1.3 Beta is not supported!
I'll try, though, but it might not work."

I think Moodle does use the same last discontinued version of HTMLArea and then should work with Safari.  Many teachers are awaiting that!  Why it does not work then?
Comment 7 Cristian Alvarado 2008-08-05 12:01:05 PDT
This appears to have been fixed now in the upcoming Moodle 2.0 build. They have moved to using TinyMCE as the default HTML editor.

http://tracker.moodle.org/browse/MDL-3084?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
Comment 8 Alexey Proskuryakov 2008-09-26 00:25:50 PDT
*** Bug 21117 has been marked as a duplicate of this bug. ***
Comment 9 Juan Falgueras 2011-02-15 17:52:11 PST
The problem with respect to Moodle bad behaviour with Webkit is that many Moodle sites are built with old versions of Moodle and are not to be changed anymore.  I would like to think it could be possible to have a plugin or a Safari patch in wich, only with this important content service it cheated it and made it think Safari is FireFox…

Could it be possible?
Comment 10 Alexey Proskuryakov 2011-02-16 10:49:09 PST
Since current versions of Moodle are not affected, I don't think that we should keep the bug open.

It might be possible to create a plugin to make old sites work indeed, but that's out of scope for the WebKit project. A third party can do that.