Bug 132284 - [New Multicolumn] event.offsetX/offsetY don't work correctly
Summary: [New Multicolumn] event.offsetX/offsetY don't work correctly
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dave Hyatt
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-28 09:36 PDT by Dave Hyatt
Modified: 2014-04-28 15:36 PDT (History)
4 users (show)

See Also:


Attachments
Patch (7.39 KB, patch)
2014-04-28 15:21 PDT, Dave Hyatt
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Hyatt 2014-04-28 09:36:47 PDT
Three form control tests fail because something is still wrong with offsetLeft/Top:

 fast/forms/number/number-spinbutton-in-multi-column.html [ Failure ]
 fast/forms/range/slider-in-multi-column.html [ Failure ]
 fast/forms/select/listbox-in-multi-column.html [ Failure ]

It's all the same bug, so fixing it should make all three test cases pass.
Comment 1 Dave Hyatt 2014-04-28 13:11:20 PDT
This is the cause of fast/events/offsetX-offsetY.html failing as well.

This boils down to mapAbsoluteToLocal not doing the right thing for new columns.
Comment 2 Dave Hyatt 2014-04-28 15:21:21 PDT
Created attachment 230326 [details]
Patch
Comment 3 WebKit Commit Bot 2014-04-28 15:23:02 PDT
Attachment 230326 [details] did not pass style-queue:


ERROR: Source/WebCore/rendering/RenderMultiColumnFlowThread.h:111:  The parameter name "transformState" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 1 in 4 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Simon Fraser (smfr) 2014-04-28 15:23:58 PDT
Comment on attachment 230326 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=230326&action=review

> Source/WebCore/rendering/RenderBoxModelObject.cpp:2646
> +    if (isBox() && o->isOutOfFlowRenderFlowThread()) {

Would be nice to rename "o" at some point.
Comment 5 Dave Hyatt 2014-04-28 15:36:00 PDT
Fix landed in r167910.