Bug 132161 - [GTK] REGRESSION(r167779) Build broken
Summary: [GTK] REGRESSION(r167779) Build broken
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other Linux
: P1 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-24 18:19 PDT by Carlos Alberto Lopez Perez
Modified: 2014-04-25 09:08 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Alberto Lopez Perez 2014-04-24 18:19:31 PDT
Revision r167779 <http://trac.webkit.org/changeset/167779> broke the GTK build.

Check the output here: http://build.webkit.org/builders/GTK%20Linux%2064-bit%20Release/builds/46809
Comment 1 Carlos Garcia Campos 2014-04-25 00:20:45 PDT
ninja: error: '../../Source/WebInspectorUI/UserInterface/External/CodeMirror/less.js', needed by 'DerivedSources/webkit2gtk/InspectorGResourceBundle.xml', missing and no known rule to make it

That file is not explicitly listed in any makefile, I bet it's the stupid cmake cache causing this, let me try a clean build.
Comment 2 Enrique Ocaña 2014-04-25 02:36:57 PDT
It was failing (again? also?) on GTK+ Linux 64-bit Debug and I removed the WebKitBuild/Debug folder in the bot to trigger a clean build on next commit. Now it seems to be building fine in that bot.

GTK Linux 32 bit Release and GTK Linux ARM Release are failing, though, but I don't have access to those bots.
Comment 3 Carlos Alberto Lopez Perez 2014-04-25 09:08:05 PDT
(In reply to comment #1)
> That file is not explicitly listed in any makefile, I bet it's the stupid cmake cache causing this, let me try a clean build.

Seems that you are right.

After forcing a clean build all GTK bots are working back: http://build.webkit.org/waterfall?category=GTK


Closing this as fixed.