Bug 132053 - [Mac] REGRESSION (r164823): Building JavaScriptCore creates files under /tmp/JavaScriptCore.dst
Summary: [Mac] REGRESSION (r164823): Building JavaScriptCore creates files under /tmp/...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Blocker
Assignee: Csaba Osztrogonác
URL:
Keywords:
Depends on:
Blocks: 129399
  Show dependency treegraph
 
Reported: 2014-04-23 02:45 PDT by Csaba Osztrogonác
Modified: 2014-04-23 07:40 PDT (History)
6 users (show)

See Also:


Attachments
Patch (2.80 KB, patch)
2014-04-23 02:51 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff
Patch (1.94 KB, patch)
2014-04-23 03:10 PDT, Mark Rowe (bdash)
no flags Details | Formatted Diff | Diff
Patch (1.94 KB, patch)
2014-04-23 03:13 PDT, Mark Rowe (bdash)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2014-04-23 02:45:45 PDT
http://trac.webkit.org/changeset/164823
http://trac.webkit.org/changeset/164828

After this change build-jsc unconditionally tries to remove and 
recreate a symlink to /tmp/JavaScriptCore.dst/usr/local/bin:
jsc -> ../../../System/Library/Frameworks/JavaScriptCore.framework/Versions/A/Resources/jsc

Additionally this symlink is broken, it points to a non-existent path.

If there are more user work on a Mac, the second user won't be able 
to remove and recreate this symlink and build-jsc will fail.

Could you possibly give us some hint how can we solve this problem?
Comment 1 Csaba Osztrogonác 2014-04-23 02:51:33 PDT
Created attachment 229969 [details]
Patch

I propose to revert r164823 and r164828, because now build-webkit always try to remove and recreate a broken and useless symlink unconditionally. It is a huge regression that now only one user can build WebKit on a Mac.
Comment 2 Mark Rowe (bdash) 2014-04-23 03:03:39 PDT
Comment on attachment 229969 [details]
Patch

Rolling those changes out reintroduces a much more serious issue. This should be trivial to fix properly, so let's just do that instead.
Comment 3 Csaba Osztrogonác 2014-04-23 03:05:04 PDT
(In reply to comment #2)
> (From update of attachment 229969 [details])
> Rolling those changes out reintroduces a much more serious issue. This should be trivial to fix properly, so let's just do that instead.

Could you give us any hint how can it be fixed properly?
Comment 4 Mark Rowe (bdash) 2014-04-23 03:10:29 PDT
Created attachment 229970 [details]
Patch
Comment 5 Mark Rowe (bdash) 2014-04-23 03:13:07 PDT
Created attachment 229971 [details]
Patch
Comment 6 Csaba Osztrogonác 2014-04-23 03:41:20 PDT
(In reply to comment #5)
> Created an attachment (id=229971) [details]
> Patch

Thanks for the patch, it fixes the multi user issue I mentioned
in the description. But I don't have expertise in Mac deployment,
I let others to review the fix.
Comment 7 WebKit Commit Bot 2014-04-23 07:40:14 PDT
Comment on attachment 229971 [details]
Patch

Clearing flags on attachment: 229971

Committed r167709: <http://trac.webkit.org/changeset/167709>
Comment 8 WebKit Commit Bot 2014-04-23 07:40:17 PDT
All reviewed patches have been landed.  Closing bug.