RESOLVED FIXED 132050
[CSS Regions] Rename objectShouldPaintInFlowRegion to something more clear
https://bugs.webkit.org/show_bug.cgi?id=132050
Summary [CSS Regions] Rename objectShouldPaintInFlowRegion to something more clear
Radu Stavila
Reported 2014-04-23 01:45:34 PDT
Rename objectShouldPaintInFlowRegion to something more clear as its no longer used just for painting, but also for hit-testing and other tasks.
Attachments
Patch (8.08 KB, patch)
2014-04-25 08:22 PDT, Radu Stavila
no flags
Radu Stavila
Comment 1 2014-04-25 08:22:58 PDT
Andreas Kling
Comment 2 2014-04-25 09:04:31 PDT
Comment on attachment 230180 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=230180&action=review r=me > Source/WebCore/rendering/RenderFlowThread.cpp:810 > +bool RenderFlowThread::objectShouldFragmentInFlowRegion(const RenderObject* object, const RenderRegion* region) const > { > ASSERT(object); > ASSERT(region); The two ASSERTs here indicate that the arguments should really be references instead of pointers. That kind of change does not belong in this patch though.
WebKit Commit Bot
Comment 3 2014-04-25 10:58:48 PDT
Comment on attachment 230180 [details] Patch Clearing flags on attachment: 230180 Committed r167810: <http://trac.webkit.org/changeset/167810>
WebKit Commit Bot
Comment 4 2014-04-25 10:58:51 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.