There is code for iOS selection that passes in the "page number" to selection to try to improve selection in vertical books. This hasn't been patched for the new multi-column layout. We should take the opportunity to clean this code up at the same time, i.e., move the function to RenderView, rename it to pageNumberForOffset, and make it clear it's not necessary for generic multi-column.
Created attachment 229563 [details]
Attachment 229563 [details] did not pass style-queue:
ERROR: Source/WebCore/rendering/RenderView.cpp:38: Alphabetical sorting problem. [build/include_order] 
Total errors found: 1 in 8 files
If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 229563 [details]
Looks good to me.
Fix landed in r167444.