Bug 13111 - Partially-loaded images change to error image when loading is stopped
Summary: Partially-loaded images change to error image when loading is stopped
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Brady Eidson
URL: http://flickr.com/explore/interesting...
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-18 13:59 PDT by mitz
Modified: 2007-03-18 17:52 PDT (History)
1 user (show)

See Also:


Attachments
Proposed fix - don't error the resource when its cancelled (2.55 KB, patch)
2007-03-18 17:45 PDT, Brady Eidson
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2007-03-18 13:59:48 PDT
When you open the URL in Safari with TOT WebKit and hit Command-. before it's finished loading but after images have started loading(*), all partially-loaded images change to the error image. This is a (recent) regression from shipping WebKit.

* - You need to be quick or have a slow connection or find a page served from a slower server.
Comment 1 mitz 2007-03-18 14:16:17 PDT
Regressed in <http://trac.webkit.org/projects/webkit/changeset/20178>.
Comment 2 mitz 2007-03-18 14:21:23 PDT
I was wrong, this is not a regression from Safari 2.0! I had forgotten it because TOT behaved differently for so long.
Comment 3 Brady Eidson 2007-03-18 17:35:22 PDT
Regression or not, Hyatt reccomended an easy fix I'm putting a patch together for right now
Comment 4 Brady Eidson 2007-03-18 17:45:46 PDT
Created attachment 13699 [details]
Proposed fix - don't error the resource when its cancelled

Proposed fix - don't error the resource when its cancelled
Comment 5 Dave Hyatt 2007-03-18 17:47:16 PDT
Comment on attachment 13699 [details]
Proposed fix - don't error the resource when its cancelled

r=me
Comment 6 Brady Eidson 2007-03-18 17:52:21 PDT
Committed in r20299