Bug 13099 - Google Reader: Scrolling past the last article in the reading list causes the entire page to scroll
Summary: Google Reader: Scrolling past the last article in the reading list causes the...
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://reader.google.com
Keywords: GoogleBug, InRadar
Depends on:
Blocks:
 
Reported: 2007-03-17 03:42 PDT by Shawn Smith
Modified: 2010-08-04 21:04 PDT (History)
3 users (show)

See Also:


Attachments
Google Reader Rendered Normally (197.44 KB, image/jpeg)
2007-03-17 03:56 PDT, Shawn Smith
no flags Details
Google Reader Scrolled Up Incorrectly. (155.98 KB, image/jpeg)
2007-03-17 03:58 PDT, Shawn Smith
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shawn Smith 2007-03-17 03:42:33 PDT
When scrolling past the last article in the reading list the entire page scrolls rather then just scrolling up the last article.  The entire UI then remains moved up the page with white space at the bottom.  Once scrolling to the top of the reading list the UI again scrolls back into the correct position.

See attached screen shots.
Comment 1 Shawn Smith 2007-03-17 03:56:04 PDT
Created attachment 13679 [details]
Google Reader Rendered Normally

This attachment shows Google Reader when the page is rendered correctly.  It also shows the result of scrolling back to the top of the reading list once the entire UI scrolled up leaving white space at the bottom.
Comment 2 Shawn Smith 2007-03-17 03:58:14 PDT
Created attachment 13680 [details]
Google Reader Scrolled Up Incorrectly.

This attachment is a screen shot of the entire Safari Window.  The white space at the bottom is displayed incorrectly when scrolling past the last article in the reading list.  Once the reading list is scrolled to the top the white space disappears.  You will notice that the grab handle in the bottom right corner is moved up by the white space at the bottom.
Comment 3 Mihai Parparita 2007-03-17 15:24:33 PDT
This is a Reader issue (that we'll be fixing), not a WebKit one.
Comment 4 David Kilzer (:ddkilzer) 2007-03-17 16:12:44 PDT
Per Comment #3, this is a Google evangelism issue.

Comment 5 Mihai Parparita 2007-05-02 06:15:21 PDT
The problem has now been fixed in Reader.
Comment 6 Rich Blinne 2007-06-10 05:35:00 PDT
Is this the annoying bouncing left pane issue? When I scroll down the left pane bounces up and down a number of times and then finally settles down. I am using the released version of Safari on a PowerPC.
Comment 7 Ernest Prabhakar 2007-06-10 20:45:51 PDT
No, it doesn't bounce (at least for me).  It simply jumps straight back to the top.
Comment 8 David Kilzer (:ddkilzer) 2008-02-03 06:25:24 PST
<rdar://problem/5721950>
Comment 9 Carlos Maeda 2008-02-15 16:46:12 PST
Also, when using the latest build on 10.5.2, the key commands seem to be mixed up. I cannot use the Page Up/Down, Home/End, or the directional keys to scroll down the different feeds like I used to. The only thing that works is the Space Bar. "J" seems to act like the Down key, "K" for up, "S" adds a star to the article, "A" opens up an "add subscription" box, "E" opens an email box, "M" marks the article as read/unread, "R" reloads the feeds,  "U" opens the subscriptions box, "F" opens up a "Friends' Articles" page, and "/" tabs to the search bar. That's all I've found so far. I'll keep looking for more. Hope this gets resolved soon as I use Google Reader as my main RSS app between my MBP and iPhone and since Webkit seems so much snappier than regular Safari.
Comment 10 David Kilzer (:ddkilzer) 2009-01-06 11:18:56 PST
Any of these issues still occurring in Google Reader?

Comment 11 Mihai Parparita 2010-08-04 21:04:16 PDT
The original issue was fixed on the Reader side long ago (see comment 4), and I was not able to reproduce the issue mentioned in comment 9.