Bug 130940 - Remove special handling of soft hyphens in search code
Summary: Remove special handling of soft hyphens in search code
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alexey Proskuryakov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-30 01:25 PDT by Alexey Proskuryakov
Modified: 2014-03-31 10:00 PDT (History)
3 users (show)

See Also:


Attachments
proposed patch (3.92 KB, patch)
2014-03-30 01:27 PDT, Alexey Proskuryakov
andersca: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2014-03-30 01:25:57 PDT
ICU knows to ignore soft hyphens, so we don't need to replace them before searching.

See aso <rdar://problem/9464270>.
Comment 1 Alexey Proskuryakov 2014-03-30 01:27:46 PDT
Created attachment 228125 [details]
proposed patch
Comment 2 Anders Carlsson 2014-03-30 12:48:41 PDT
Comment on attachment 228125 [details]
proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=228125&action=review

> Source/WebCore/ChangeLog:3
> +        Remove special handling of soft hyphens in search code

Why?
Comment 3 Alexey Proskuryakov 2014-03-30 19:57:33 PDT
> Why?

Quoting bug description, "ICU knows to ignore soft hyphens, so we don't need to replace them before searching."
Comment 4 Anders Carlsson 2014-03-31 07:45:01 PDT
(In reply to comment #3)
> > Why?
> 
> Quoting bug description, "ICU knows to ignore soft hyphens, so we don't need to replace them before searching."

Ah! Can you put that in the ChangeLog as well?
Comment 5 Alexey Proskuryakov 2014-03-31 09:33:05 PDT
Committed <http://trac.webkit.org/r166507>.
Comment 6 Darin Adler 2014-03-31 09:41:35 PDT
(In reply to comment #0)
> ICU knows to ignore soft hyphens

Has that always been true, or is this a recent development?
Comment 7 Alexey Proskuryakov 2014-03-31 10:00:13 PDT
I've been told that ICU "already" does this, and EWS confirmed that it's true as of 10.8 at least. I think that this code was added before Mac WebKit started to use ICU, and it was recently needed because of other non-ICU platforms that we used to support.

This is some history that I'm aware of, although it doesn't fully answer your question.