Bug 13087 - REGRESSION: Allow setting the checked attribute in js and in markup for unnamed radio buttons (dominoes)
Summary: REGRESSION: Allow setting the checked attribute in js and in markup for unnam...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Adele Peterson
URL: http://www.dominos.com
Keywords: HasReduction, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-03-15 13:19 PDT by Beth Dakin
Modified: 2007-03-19 17:46 PDT (History)
0 users

See Also:


Attachments
reduction: self-closing input tag (32 bytes, text/html)
2007-03-15 21:56 PDT, Beth Dakin
no flags Details
patch (8.62 KB, patch)
2007-03-19 17:30 PDT, Adele Peterson
bdakin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Beth Dakin 2007-03-15 13:19:23 PDT
1. Go to http://www01.order.dominos.com/olo/faces/order/step2_choose_pizza.jsp
2. Enter an address. (This part is tricky, some addresses don't provide the pizza store that repros the bug. One that does is 218 Broadway, Revere, MA 02151)
2. Confirm the address and nearest store by clicking "Next"
3. Click "Choose size and crust" under "Build your own pizza"
4. At any given time, one of the radio buttons in the "Hand-tossed," "Deep-dish," "Thin," or "Brooklyn" column should be selected, but as you select them, the button never turns blue. The selection registers in that the view changes, but the button never looks pressed, and it isn't actually pressed.

This bug prevents ordering a pizza since this generates an error when you try to add the pizza, saying that you have not selected a size or crust.
Comment 1 Beth Dakin 2007-03-15 13:19:46 PDT
<rdar://problem/5064316>
Comment 2 Beth Dakin 2007-03-15 13:21:36 PDT
Does this automatically cc me? I can never remember...
Comment 3 David Kilzer (:ddkilzer) 2007-03-15 19:13:14 PDT
(In reply to comment #2)
> Does this automatically cc me? I can never remember...

Yes, it should, but what email you get depends on your settings.  (For example, if you don't care when people just add a Cc: address, you won't get email.)

Comment 4 Beth Dakin 2007-03-15 21:56:54 PDT
Created attachment 13654 [details]
reduction: self-closing input tag

Here is a reduction. Looks like we used to allow self-closing input tags but don't anymore. Firefox allows them too.
Comment 5 Beth Dakin 2007-03-15 21:57:31 PDT
Thanks, Dave!
Comment 6 Beth Dakin 2007-03-15 22:06:24 PDT
I take that back. repros without self-closing as well.
Comment 7 Beth Dakin 2007-03-15 22:09:50 PDT
It's the name attribute. Adding a name attribute makes it work.
Comment 8 Beth Dakin 2007-03-16 11:08:44 PDT
Comment on attachment 13654 [details]
reduction: self-closing input tag

Okay, it turns out this reduction is not valid. Our behavior here matches IE, and we made the change intentionally. There is some other JavaScript at the site that makes the radio button still click in IE. I am working on another reduction.
Comment 9 Adele Peterson 2007-03-19 17:30:49 PDT
Created attachment 13711 [details]
patch
Comment 10 Adele Peterson 2007-03-19 17:40:12 PDT
We were matching a WinIE quirk that does not allow a user to check and uncheck an unnamed radio button.  But they still allow the checked attribute to be set in html, and changed in javascript.  So this change matches that behavior.
Comment 11 Beth Dakin 2007-03-19 17:43:23 PDT
Comment on attachment 13711 [details]
patch

yay! r=me!
Comment 12 Adele Peterson 2007-03-19 17:46:15 PDT
Committed revision 20333.