Bug 13060 - REGRESSION: Repro ASSERT failure in Cache::adjustSize running layout tests
Summary: REGRESSION: Repro ASSERT failure in Cache::adjustSize running layout tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar, LayoutTestFailure, Regression
Depends on:
Blocks:
 
Reported: 2007-03-13 13:04 PDT by Geoffrey Garen
Modified: 2007-03-14 13:59 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey Garen 2007-03-13 13:04:34 PDT
This bug is also in Radar as <rdar://5060208>

* STEPS TO REPRODUCE
run-webkit-tests --leaks fast/dom

[12:47pm] darin: ASSERTION FAILED: delta >= 0 || ((int)m_liveResourcesSize + delta >= 0)
[12:47pm] darin: (/Users/darin/Safari/OpenSource/WebCore/loader/Cache.cpp:352 void WebCore::Cache::adjustSize(bool, int))

Darin says this is reproducible 100% of the time.

-------------------------------------------

<GMT13-Mar-2007 19:52:36GMT> Geoff Garen:
I think this is a regression caused by Hyatt's recent cache changes.
Comment 1 Antti Koivisto 2007-03-14 10:09:10 PDT
CachedScript is dereferenced twice in fast/dom/script-element-gc.html, causing m_liveResourcesSize underflow.
Comment 2 Antti Koivisto 2007-03-14 13:59:30 PDT
r20194