Bug 13034 - can't click on link on Fidelity.com index fund page
Summary: can't click on link on Fidelity.com index fund page
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://personal.fidelity.com/products...
Keywords: HasReduction, InRadar
Depends on:
Blocks:
 
Reported: 2007-03-10 11:09 PST by Darin Adler
Modified: 2010-07-24 17:08 PDT (History)
4 users (show)

See Also:


Attachments
Reduction (225 bytes, text/html)
2007-03-10 13:07 PST, mitz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2007-03-10 11:09:30 PST
Go to <http://www.fidelity.com>
Click on the Investment Products item in the horizontal menu at the top of the page
Click on the Mutual Funds link in the horizontal menu that appears below it

You should now be at <http://personal.fidelity.com/products/funds/funds_frame.shtml.cvsr>. You can just start with this step if you like, assuming the site hasn't changed much.
Click on the Index Funds link on the vertical menu on the left side of the page

Move the mouse over the Fidelity Stock Index link in the middle of the page, inside the "Browse/Buy Fidelity Funds" box. Note that the cursor does not change to a link cursor. You also can't click on the link.

Same problem with released Safari and TOT.

<rdar://problem/5054845>
Comment 1 mitz 2007-03-10 13:00:34 PST
The links are contained in a div with z-index -1. Changing the z-index to 0 or higher makes the links responsive.
Comment 2 mitz 2007-03-10 13:07:50 PST
Created attachment 13579 [details]
Reduction

> The links are contained in a div with z-index -1. Changing the z-index to 0 or
> higher makes the links responsive.

That appears to be all there is to it.
Comment 3 Dave Hyatt 2007-03-10 15:03:20 PST
My understanding is that this behavior is correct according to the CSS2.1 spec.  Maybe Ian can comment on this.  The <body> element does not establish a stacking context.  The root element does.  Therefore the <div> is a stacking context inside of the root with a negative z-index.  That means it is underneath the <body> element.  Since backgrounds are not "click-through" in CSS even when transparent, this means that the <body> is what is hit, not the contents of the <div>.

This test case does indicate to me that perhaps CSS should revisit whether or not the <body> establishes a stacking context or not.

Comment 4 Dave Hyatt 2007-03-10 16:41:18 PST
This should probably be evangelized I guess.
Comment 5 Alexey Proskuryakov 2010-07-24 17:08:17 PDT
This is not reproducible with Safari 4.0.5 or Safari 5, possibly due to site change.