We'd better to remove Async keyword from the APIs for the consistency.
Like https://lists.webkit.org/pipermail/webkit-efl/2014-March/000583.html, We'd better to follow EFL style more for the async APIs.
Created attachment 227006 [details] Patch
Comment on attachment 227006 [details] Patch r=me based on efl mailing list discussion.
Comment on attachment 227006 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=227006&action=review > Source/WebKit2/UIProcess/API/efl/ewk_application_cache_manager.cpp:45 > +struct Get_Origins_Async_Data { *Ewk_Application_Cache_Origins_Async_Data* seems to be more clear. > Source/WebKit2/UIProcess/API/efl/ewk_cookie_manager.cpp:195 > struct Get_Hostnames_Async_Data { *Ewk_Cookie_Manager_Hostnames_Async_Data*? > Source/WebKit2/UIProcess/API/efl/ewk_database_manager.cpp:66 > struct Ewk_Database_Origins_Async_Get_Context { *Ewk_Database_Origins_Async_Data*? > Source/WebKit2/UIProcess/API/efl/ewk_storage_manager.cpp:66 > struct Ewk_Storage_Origins_Async_Get_Context { *Ewk_Storage_Origins_Async_Data*?
(In reply to comment #4) > (From update of attachment 227006 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=227006&action=review > > > Source/WebKit2/UIProcess/API/efl/ewk_application_cache_manager.cpp:45 > > +struct Get_Origins_Async_Data { > > *Ewk_Application_Cache_Origins_Async_Data* seems to be more clear. > > > Source/WebKit2/UIProcess/API/efl/ewk_cookie_manager.cpp:195 > > struct Get_Hostnames_Async_Data { > > *Ewk_Cookie_Manager_Hostnames_Async_Data*? > > > Source/WebKit2/UIProcess/API/efl/ewk_database_manager.cpp:66 > > struct Ewk_Database_Origins_Async_Get_Context { > > *Ewk_Database_Origins_Async_Data*? > > > Source/WebKit2/UIProcess/API/efl/ewk_storage_manager.cpp:66 > > struct Ewk_Storage_Origins_Async_Get_Context { > > *Ewk_Storage_Origins_Async_Data*? Like discussed in IRC, I agree that it looks ugly but I am not sure whether I can rename them in this bug. gyuyoung, what do you think about it? If I can rename them in this bug, I will rebase the patch.
Comment on attachment 227006 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=227006&action=review >>> Source/WebKit2/UIProcess/API/efl/ewk_application_cache_manager.cpp:45 >>> +struct Get_Origins_Async_Data { >> >> *Ewk_Application_Cache_Origins_Async_Data* seems to be more clear. > > Like discussed in IRC, I agree that it looks ugly but I am not sure whether I can rename them in this bug. > > gyuyoung, what do you think about it? > > If I can rename them in this bug, I will rebase the patch. I don't mind to rename these in this patch together.
Created attachment 227137 [details] Patch
Comment on attachment 227137 [details] Patch Thanks for renaming the structures. Much better!
Comment on attachment 227137 [details] Patch Clearing flags on attachment: 227137 Committed r165864: <http://trac.webkit.org/changeset/165864>
All reviewed patches have been landed. Closing bug.