Split this off from 129395
Created attachment 227530 [details] the patch
Attachment 227530 [details] did not pass style-queue: ERROR: Source/WebCore/replay/SerializationMethods.cpp:70: _key is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 1 in 8 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 227530 [details] the patch View in context: https://bugs.webkit.org/attachment.cgi?id=227530&action=review r=me > Source/WebCore/replay/SerializationMethods.cpp:148 > + decodedValue = textWasDecoded ? KeypressCommand(commandName, text) : KeypressCommand(commandName); The origin os "textWasDecoded" is pretty cryptic, but I think its fine. > Source/WebCore/replay/SerializationMethods.cpp:154 > + PlatformKeyboardEventAppKit(const PlatformKeyboardEvent& event, bool handledByInputMethod, Vector<KeypressCommand> commands) Nit: Vector<>& commands
Comment on attachment 227530 [details] the patch View in context: https://bugs.webkit.org/attachment.cgi?id=227530&action=review >> Source/WebCore/replay/SerializationMethods.cpp:148 >> + decodedValue = textWasDecoded ? KeypressCommand(commandName, text) : KeypressCommand(commandName); > > The origin os "textWasDecoded" is pretty cryptic, but I think its fine. Yeah.. not my favorite case. I decided to prepend the key name so that capitalization is consistent for single and multi-word keys. >> Source/WebCore/replay/SerializationMethods.cpp:154 >> + PlatformKeyboardEventAppKit(const PlatformKeyboardEvent& event, bool handledByInputMethod, Vector<KeypressCommand> commands) > > Nit: Vector<>& commands OK
Committed r166212: <http://trac.webkit.org/changeset/166212>