Bug 13009 - REGRESSION (r20042): Console spews "CGContextGetType: invalid context" non-stop on web site
Summary: REGRESSION (r20042): Console spews "CGContextGetType: invalid context" non-st...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://tf1.lci.fr/
Keywords: InRadar, NeedsReduction, Regression
Depends on:
Blocks:
 
Reported: 2007-03-07 23:17 PST by David Kilzer (:ddkilzer)
Modified: 2007-03-08 19:15 PST (History)
4 users (show)

See Also:


Attachments
Checks for null ptr before calling WKCGContextIsBitmapContext. (1.97 KB, patch)
2007-03-08 14:45 PST, Bruce Q. Hammond
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2007-03-07 23:17:49 PST
Summary:

The following message spews non-stop to the console when the URL (http://tf1.lci.fr/) is loaded:

CGContextGetType: invalid context

This is a fairly recent regression (within the last 24 hours).

Steps to reproduce:

1. Open WebKit debug build.
2. Access URL:  http://tf1.lci.fr/
3. Wait for page to load.

Expected results:

No "CGContextGetType: invalid context" messages should be printed to the console.

Actual results:

The "CGContextGetType: invalid context" messages are printed to the console non-stop until the page is closed.

Regression:

This wasn't happening with debug builds less than 24 hours ago.
Comment 1 David Kilzer (:ddkilzer) 2007-03-07 23:20:22 PST
Note that the URL is from Bug 12980.

Comment 2 Stephanie Lewis 2007-03-07 23:38:41 PST
<rdar://problem/5048788>
Comment 3 David Kilzer (:ddkilzer) 2007-03-07 23:51:09 PST
Of course, I can't reproduce it now.  Probably a particular ad was being displayed.

If anyone sees this again, please save a webarchive of the page.
Comment 4 David Kilzer (:ddkilzer) 2007-03-08 00:05:17 PST
(In reply to comment #3)
> Of course, I can't reproduce it now.  Probably a particular ad was being
> displayed.

I was missing a step in the steps to reproduce:

1. Open WebKit debug build.
2. Access URL:  http://tf1.lci.fr/
3. Wait for page to load.
4. Hide Safari.

As soon as Safari is hidden, the message starts spewing to the console and never stops until the browser window is closed.

Comment 5 David Kilzer (:ddkilzer) 2007-03-08 00:19:30 PST
This is a regression from r20042 which was the fix for Bug 12515.

Comment 6 David Kilzer (:ddkilzer) 2007-03-08 00:59:12 PST
I'm also seeing these console messages sporadically (on this URL, for example: http://www.flickr.com/search/?q=cute+kittens&s=int):

Not a JPEG file: starts with 0x7b 0x35
Not a JPEG file: starts with 0x7b 0x35
Not a JPEG file: starts with 0x7b 0xbd
Not a JPEG file: starts with 0x7b 0x35
Not a JPEG file: starts with 0x7b 0xcb
Not a JPEG file: starts with 0x7b 0x35
Not a JPEG file: starts with 0x7b 0x35
Not a JPEG file: starts with 0x7b 0x35
Not a JPEG file: starts with 0x7b 0x35

I'm not sure if this is caused by r20042 or not, though.

Comment 7 David Kilzer (:ddkilzer) 2007-03-08 01:33:18 PST
(In reply to comment #6)
> I'm also seeing these console messages sporadically (on this URL, for example:
> http://www.flickr.com/search/?q=cute+kittens&s=int):
> 
> Not a JPEG file: starts with 0x7b 0x35
> [...]
> 
> I'm not sure if this is caused by r20042 or not, though.

This appears to have been a different issue.  Please ignore it.

Comment 8 David Kilzer (:ddkilzer) 2007-03-08 01:35:04 PST
(In reply to comment #7)
> This appears to have been a different issue.  Please ignore it.

And is fixed as of r20057.

Comment 9 Matt Lilek 2007-03-08 14:03:14 PST
(In reply to comment #4)
> 
> As soon as Safari is hidden, the message starts spewing to the console and
> never stops until the browser window is closed.
> 

The website http://weplayanything.com spews this before anything is even rendered, without having to hide Safari.
Comment 10 Bruce Q. Hammond 2007-03-08 14:45:56 PST
Created attachment 13549 [details]
Checks for null ptr before calling WKCGContextIsBitmapContext.

A fairly trivial (low-risk) fix for this issue
Comment 11 Darin Adler 2007-03-08 14:47:08 PST
Comment on attachment 13549 [details]
Checks for null ptr before calling WKCGContextIsBitmapContext.

r=me

Do you know why there's a null context?
Comment 12 Mark Rowe (bdash) 2007-03-08 19:15:53 PST
Landed in r20077.