Bug 130074 - [EFL] TiledBackingStore: Fails to create a tile.
Summary: [EFL] TiledBackingStore: Fails to create a tile.
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-11 01:48 PDT by Jeong Jin Gyeong
Modified: 2017-03-11 10:49 PST (History)
11 users (show)

See Also:


Attachments
Patch (2.46 KB, patch)
2014-03-11 02:27 PDT, Jeong Jin Gyeong
no flags Details | Formatted Diff | Diff
Expected(Google Chrome 31) vs Actual(r168420 EFL MiniBrowser). The cover of right side does not display. (591.13 KB, image/png)
2014-05-07 07:58 PDT, Jeong Jin Gyeong
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeong Jin Gyeong 2014-03-11 01:48:11 PDT
Realistic case:
 http://vanderlee.github.io/coverflow/

Problem:
 Some cover doesn't display until it's animated.
Comment 1 Jeong Jin Gyeong 2014-03-11 02:27:36 PDT
Created attachment 226401 [details]
Patch
Comment 2 Gyuyoung Kim 2014-05-07 03:00:23 PDT
Can you add a test case as well ?
Comment 3 Jeong Jin Gyeong 2014-05-07 03:53:56 PDT
Do you mean a minimal test case?
I'm not sure, I think that is unpredictable to know which content will not be displayed.

Is it still problem on the nightly build? I didn't follow this for a while.

(In reply to comment #2)
> Can you add a test case as well ?
Comment 4 Gyuyoung Kim 2014-05-07 03:56:48 PDT
(In reply to comment #3)
> Do you mean a minimal test case?
> I'm not sure, I think that is unpredictable to know which content will not be displayed.

If you can't add a test in order to reproduce this problem, I'm not sure if we can land this patch.

> Is it still problem on the nightly build? I didn't follow this for a while.

I don't know it. If this issue is not reproduced anymore, I wanna close this bug.
Comment 5 Jeong Jin Gyeong 2014-05-07 07:58:44 PDT
Created attachment 230998 [details]
Expected(Google Chrome 31) vs Actual(r168420 EFL MiniBrowser). The cover of right side does not display.

Sorry for I'm late. I successfully reproduced at r168420. Please check the image I attached.
Comment 6 Gyuyoung Kim 2014-05-09 04:24:42 PDT
(In reply to comment #5)
> Created an attachment (id=230998) [details]
> Expected(Google Chrome 31) vs Actual(r168420 EFL MiniBrowser). The cover of right side does not display.
> 
> Sorry for I'm late. I successfully reproduced at r168420. Please check the image I attached.

Thank you for the screenshot. Then, can't you make a test case to reproduce this issue by using the problem demo ?
Comment 7 Gyuyoung Kim 2015-02-03 07:33:18 PST
Comment on attachment 226401 [details]
Patch

Cleared review? from attachment 226401 [details] so that this bug does not appear in http://webkit.org/pending-review. If you would like this patch reviewed, please attach it to a new bug or this bug again.
Comment 8 Michael Catanzaro 2017-03-11 10:49:43 PST
Closing this bug because the EFL port has been removed from trunk.

If you feel this bug applies to a different upstream WebKit port and was closed in error, please either update the title and reopen the bug, or leave a comment to request this.