Bug 130052 - Web Inspector: synchronous XHR that times out will mysteriously hang Inspector
Summary: Web Inspector: synchronous XHR that times out will mysteriously hang Inspector
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL: https://developer.mozilla.org/media/u...
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-03-10 16:46 PDT by Brian Burg
Modified: 2016-09-09 14:33 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Burg 2014-03-10 16:46:57 PDT
It would be great if we could:

1. Avoid hanging the inspector when the page does a sync XHR (use a separate process?)
2. Give feedback to the user that their page is stuck because of a sync XHR

If there's a bug for (1), then please mark it as blocking this bug, which should focus on explaining why their page is (sensically) hanging (not the inspector, which should never hang).
Comment 1 Timothy Hatcher 2014-03-12 11:50:18 PDT
There is a radar about using a separate process for the Inspector, but not a bugzilla bug.
Comment 2 David Kilzer (:ddkilzer) 2016-09-09 11:11:30 PDT
<rdar://problem/28228559>
Comment 3 Brian Burg 2016-09-09 14:33:26 PDT
I think this is no longer relevant as Inspector is out of process, and a developer can easily pause the debugger or look at timelines if they think the page is hung.