Bug 129915 - Continue hangs when performing for-of over arguments
Summary: Continue hangs when performing for-of over arguments
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Oliver Hunt
URL:
Keywords:
: 129916 129917 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-03-07 14:24 PST by Oliver Hunt
Modified: 2014-03-07 17:12 PST (History)
0 users

See Also:


Attachments
Patch (4.72 KB, patch)
2014-03-07 16:18 PST, Oliver Hunt
ggaren: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Hunt 2014-03-07 14:24:55 PST
Continue hangs when performing for-of over arguments
Comment 1 Oliver Hunt 2014-03-07 14:29:55 PST
*** Bug 129917 has been marked as a duplicate of this bug. ***
Comment 2 Oliver Hunt 2014-03-07 14:30:08 PST
*** Bug 129916 has been marked as a duplicate of this bug. ***
Comment 3 Oliver Hunt 2014-03-07 16:18:06 PST
Created attachment 226183 [details]
Patch
Comment 4 Geoffrey Garen 2014-03-07 16:35:33 PST
Comment on attachment 226183 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=226183&action=review

r=me

> Source/JavaScriptCore/bytecompiler/BytecodeGenerator.cpp:2451
> +        emitJump(loopCondition.get());

Our other looping nodes prefer to emit op_less twice -- once at the head of the loop, and once at the tail. That makes the CFG more amenable to optimization.
Comment 5 Oliver Hunt 2014-03-07 17:12:21 PST
Committed r165306: <http://trac.webkit.org/changeset/165306>