Bug 129499 - In Xcode builds, WebKitLibraries aren't copied into BUILT_PRODUCTS_DIR
Summary: In Xcode builds, WebKitLibraries aren't copied into BUILT_PRODUCTS_DIR
Status: RESOLVED DUPLICATE of bug 132619
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-28 11:26 PST by BJ Burg
Modified: 2015-09-10 15:22 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BJ Burg 2014-02-28 11:26:52 PST
For open source builds, it seems you must first run build-webkit at the command line because copy-webkitlibraries-to-product-directory is never invoked by the Xcode projects. However, build-webkit doesn't expose any way to change the build root. This is a pain if you have a feature flag and want one svn checkout but two build directories to test the build with/without the flag enabled.

So I have to manually execute the script:

perl Tools/Scripts/copy-webkitlibraries-to-product-directory --wksi /Users/bburg/repos/webkit-patches/OpenSource/WebKitBuild/Vanilla/Debug

Is there something I'm missing here?
Comment 1 BJ Burg 2015-09-08 09:30:05 PDT
I can't directly verify this bug anymore, but it seems it should be fixed by the adjustments to product directory lookup made awhile ago.

*** This bug has been marked as a duplicate of bug 132619 ***
Comment 2 Andy Estes 2015-09-08 10:48:14 PDT
copy-webkitlibraries-to-product-directory is now executed as a build pre-action when you're using a workspace. I'm not sure when that was added.
Comment 3 Andy Estes 2015-09-08 10:49:41 PDT
(In reply to comment #2)
> copy-webkitlibraries-to-product-directory is now executed as a build
> pre-action when you're using a workspace.

The WebKit workspace, that is.
Comment 4 Andy Estes 2015-09-10 15:22:55 PDT
One more thing to note: you actually can tell build-webkit to use a different build directory by setting $WEBKIT_OUTPUTDIR in the environment.