Bug 12944 - Site Compatibility With North Texas Tollway
Summary: Site Compatibility With North Texas Tollway
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.ntta.org/AboutUs/Traffic?t...
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-02 05:16 PST by Jordan Breeding
Modified: 2008-12-26 11:51 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jordan Breeding 2007-03-02 05:16:24 PST
The link (http://www.ntta.org/AboutUs/Traffic?tabid=speed) is the page you go to if you go to www.ntta.org and then click on "go to driving conditions map" towards the bottom right.  The problem is that in Firefox/IE when you go to that page there is no info box in the upper left of the map, then you hover over a highway segment and the box pops up.  In Safari/WebKit you have to first move your cursor in and out of the boxes that are already there until they are all gone, then you can finally hover over highway segments to see a sepcific set of times.
Comment 1 Alexey Proskuryakov 2007-03-02 11:39:06 PST
Additionally, Firefox displays a nice fade-out effect for the box.

The box is hidden with CSS style "filter:alpha(opacity=0);-moz-opacity: 0.0;". Filter is an IE extension, and -moz-opacity is, obviously, a Mozilla one.

I'm not sure if any of these should be implemented in WebKit - if not, this is a evangelism bug (because WebKit does implement CSS3 opacity). See also: bug 9210.
Comment 2 Jordan Breeding 2007-03-19 01:51:45 PDT
Well however this ends up getting fixed it would be nice to have it finally fixed.  I tried contacting the website support people for the website directly a while back to report that Safari/Webkit doesn't work correctly but I never heard back.
Comment 3 Mark Malone 2007-03-20 06:35:18 PDT
Please contact the site owner and recommend that they include the W3C standard implementation for Opacity in addition to the other browser specific hacks. 

Something like:

filter:alpha(opacity=0);-moz-opacity: 0.0;opacity:0"

should float their boat.  http://www.mandarindesign.com/opacity.html has a good review and the W3C recommendations are here: http://www.w3.org/TR/css3-color/#transparency
Comment 4 Jordan Breeding 2007-03-22 23:19:14 PDT
I tried contacting the website about this for the second time but I still haven't ever heard anything back from them.  They do claim Safari compatibility and the rest of their website works well with Safari.
Comment 5 Robert Blaut 2008-12-26 11:51:48 PST
I think the reported site works actually properly in the latest WebKit. I compared it with Firefox and saw no difference. So the bug is fixed. Jordan, feel free to reopen the report you found other glitches.