Bug 12929 - WebKit won't always jump to anchor when following a link with an anchor
Summary: WebKit won't always jump to anchor when following a link with an anchor
Status: RESOLVED DUPLICATE of bug 12420
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://developer.apple.com/documentat...
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-28 09:15 PST by Rosyna
Modified: 2007-02-28 13:42 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rosyna 2007-02-28 09:15:35 PST
If I go to a link with an anchor in it such as http://developer.apple.com/documentation/Carbon/Reference/Memory_Manager/Reference/reference.html#//apple_ref/c/func/HandToHand sometimes WebKit won't jump to the link. It seems to depend entirely on the speed of the network connection and the length of the page. So if it is in cache, the anchors usually work.

Another example (not hosted on an apple server) is http://www.unsanity.org/archives/000457.php#ICBM_Definition

almost like WebKit is trying to jump as soon as the first paint is done on a page and doesn't attempt to jump again when the page is entirely loaded. Or something
Comment 1 David Kilzer (:ddkilzer) 2007-02-28 13:42:00 PST


*** This bug has been marked as a duplicate of 12420 ***