Bug 12917 - mouseout event does not occur after scaling use instance
Summary: mouseout event does not occur after scaling use instance
Status: RESOLVED DUPLICATE of bug 12936
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.carto.net/neumann/webkitsv...
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-27 14:01 PST by Andreas Neumann
Modified: 2007-03-01 10:06 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Neumann 2007-02-27 14:01:10 PST
in the given example if one mouses over the arrow (use instance) only the mouseover event is triggered but not the mouseout event. Opera and Mozilla render this example correctly.

Thank you for having a look at this problem.

Andreas
Comment 1 Nikolas Zimmermann 2007-03-01 09:27:17 PST
Bug fixed in my hdd. The use shadow tree was always regenerated, even if you just altered the transform attribute -> before the mouseout event was send, the tree was already regenerated so the actual dispatch didn't take any effect. This was a tricky bug, glad you found it!
Comment 2 Nikolas Zimmermann 2007-03-01 10:06:48 PST

*** This bug has been marked as a duplicate of 12936 ***