Bug 128843 - rename WebVideoFullscreen* classes with better names.
Summary: rename WebVideoFullscreen* classes with better names.
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jeremy Jones
Depends on:
Reported: 2014-02-14 14:10 PST by Jeremy Jones
Modified: 2014-03-07 21:26 PST (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Jones 2014-02-14 14:10:50 PST
WebVideoFullscreenInterface is ambiguous because it sounds like a class interface and a user interface.
WebVideoFullscreenModelMediaElement sounds like it is a type of MediaElement, but it is a model object.

These and the related classes should be given better, more descriptive names.
Comment 1 Jeremy Jones 2014-03-07 21:26:59 PST
Remove the "Web" prefix. It is unnecessary for C++ classes.