Bug 128603 - [EFL][WK2] Buildfix after bug128569
Summary: [EFL][WK2] Buildfix after bug128569
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Critical
Assignee: Grzegorz Czajkowski
URL:
Keywords:
Depends on:
Blocks: 128569
  Show dependency treegraph
 
Reported: 2014-02-11 08:26 PST by Csaba Osztrogonác
Modified: 2014-12-03 07:54 PST (History)
13 users (show)

See Also:


Attachments
Patch (6.82 KB, patch)
2014-02-12 05:10 PST, Grzegorz Czajkowski
no flags Details | Formatted Diff | Diff
patch for landing (6.81 KB, patch)
2014-02-13 00:24 PST, Grzegorz Czajkowski
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2014-02-11 08:26:15 PST
http://trac.webkit.org/changeset/163856 broke the EFL build, but 
it was reverted, because it broke regression tests on Mac.

This bug is to fix the EFL build before or after relanding the patch in bug128569

cc Grzegorz who implemented the rest of TextCheckerEfl.cpp and other EFL developers.
Comment 1 Grzegorz Czajkowski 2014-02-12 02:16:01 PST
Thanks. Seems that we need to apply StringView to TextCheckerEfl.cpp due to TextChecker.h is likely to use it. I'll take care of it.
Comment 2 Grzegorz Czajkowski 2014-02-12 05:10:23 PST
Created attachment 223962 [details]
Patch
Comment 3 Anders Carlsson 2014-02-12 07:44:57 PST
Comment on attachment 223962 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=223962&action=review

The patch in bug 128569 was rolled out, so this won't be needed until it's re-landed.

> Source/WebKit2/UIProcess/efl/TextCheckerEfl.cpp:124
> +static unsigned nextWordOffset(const StringView& stringView, unsigned currentOffset)

StringView should always be passed by value since it's such a small struct that it fits in two register.
Comment 4 Grzegorz Czajkowski 2014-02-13 00:24:41 PST
Created attachment 224051 [details]
patch for landing
Comment 5 Csaba Osztrogonác 2014-12-03 07:54:14 PST
We don't need it anymore.