<rdar://problem/15194194>
Created attachment 223432 [details] very preliminary Caveats: - will not build for the simulator - forward swipe isn't working yet (no idea why) - doesn't inform the app about the swipe state - no changelog - patch appears bigger than it actually is because of a rename (will split that out)
Attachment 223432 [details] did not pass style-queue: ERROR: Source/WebKit2/UIProcess/mac/ViewSnapshotStore.h:35: Alphabetical sorting problem. [build/include_order] [4] ERROR: Source/WebKit2/UIProcess/ios/ViewGestureControllerIOS.h:37: _UIViewControllerTransitionContext is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WebKit2/UIProcess/ios/ViewGestureControllerIOS.h:38: _UINavigationInteractiveTransitionBase is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WebKit2/UIProcess/ios/ViewGestureControllerIOS.h:54: The parameter name "transition" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 4 in 19 files If any of these errors are false positives, please file a bug against check-webkit-style.
Created attachment 223511 [details] patch
Attachment 223511 [details] did not pass style-queue: ERROR: Source/WebKit2/UIProcess/mac/ViewGestureController.h:39: _UIViewControllerTransitionContext is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WebKit2/UIProcess/mac/ViewGestureController.h:40: _UINavigationInteractiveTransitionBase is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 2 in 18 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 223511 [details] patch View in context: https://bugs.webkit.org/attachment.cgi?id=223511&action=review > Source/WebKit2/UIProcess/API/ios/WKContentView.h:52 > +- (CGImageRef)takeViewSnapshotForContentView:(WKContentView *)contentView; I think this should return a RetainPtr as well. > Source/WebKit2/UIProcess/ios/ViewGestureControllerIOS.mm:52 > +@interface WKSwipeInteractiveTransitionDelegate : NSObject <_UINavigationInteractiveTransitionBaseDelegate> This is not a delegate. How about TransitionController?
Created attachment 223516 [details] patch
Attachment 223516 [details] did not pass style-queue: ERROR: Source/WebKit2/UIProcess/mac/ViewGestureController.h:39: _UIViewControllerTransitionContext is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WebKit2/UIProcess/mac/ViewGestureController.h:40: _UINavigationInteractiveTransitionBase is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 2 in 18 files If any of these errors are false positives, please file a bug against check-webkit-style.
Created attachment 223518 [details] patch
Attachment 223518 [details] did not pass style-queue: ERROR: Source/WebKit2/UIProcess/mac/ViewGestureController.h:39: _UIViewControllerTransitionContext is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WebKit2/UIProcess/mac/ViewGestureController.h:40: _UINavigationInteractiveTransitionBase is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 2 in 18 files If any of these errors are false positives, please file a bug against check-webkit-style.
http://trac.webkit.org/changeset/163666