NavigationState should be a PageLoadState::Observer
Created attachment 223027 [details] Patch
Comment on attachment 223027 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=223027&action=review > Source/WebKit2/UIProcess/API/Cocoa/WKWebViewInternal.h:38 > +#if PLATFORM(IOS) > +#import "WKContentViewInternal.h" > +#import <UIKit/UIScrollView_Private.h> > +#import <UIKit/_UIWebViewportHandler.h> > + > +#define WK_WEB_VIEW_PROTOCOLS <UIScrollViewDelegate, WKContentViewDelegate, _UIWebViewportHandlerDelegate> > +#endif The paragraphing here is hard to read. Iād almost prefer two separate if statements. > Source/WebKit2/UIProcess/API/Cocoa/WKWebViewInternal.h:42 > +#if PLATFORM(MAC) && !PLATFORM(IOS) > +#define WK_WEB_VIEW_PROTOCOLS > +#endif Maybe just: #if !defined(WK_WEB_VIEW_PROTOCOLS) #define WK_WEB_VIEW_PROTOCOLS #endif > Source/WebKit2/UIProcess/Cocoa/NavigationState.h:92 > + // PageLoadState::Observer > + virtual void willChangeIsLoading() override; > + virtual void didChangeIsLoading() override; Without a blank line, this comment seems to be grouped with only these first two overrides, so I suggest different formatting. > Source/WebKit2/UIProcess/Cocoa/NavigationState.mm:340 > + printf("%s!\n", __PRETTY_FUNCTION__); Do we really want to land this? > Source/WebKit2/UIProcess/Cocoa/NavigationState.mm:345 > + printf("%s!\n", __PRETTY_FUNCTION__); Do we really want to land this?
Committed r163332: <http://trac.webkit.org/changeset/163332>
Comment on attachment 223027 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=223027&action=review > Source/WebKit2/UIProcess/Cocoa/NavigationState.mm:34 > +#import "PageLoadState.h" P < W > Source/WebKit2/UIProcess/Cocoa/NavigationState.mm:340 > + printf("%s!\n", __PRETTY_FUNCTION__); No! > Source/WebKit2/UIProcess/Cocoa/NavigationState.mm:345 > + printf("%s!\n", __PRETTY_FUNCTION__); No!