Bug 127900 - Web Inspector: Show profile data in the discrete Scripts timeline view
Summary: Web Inspector: Show profile data in the discrete Scripts timeline view
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Timothy Hatcher
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-01-30 02:35 PST by Timothy Hatcher
Modified: 2014-01-30 17:32 PST (History)
4 users (show)

See Also:


Attachments
Patch (50.31 KB, patch)
2014-01-30 02:43 PST, Timothy Hatcher
joepeck: review+
timothy: commit-queue-
Details | Formatted Diff | Diff
Screenshot (1.14 MB, image/png)
2014-01-30 02:46 PST, Timothy Hatcher
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Hatcher 2014-01-30 02:35:21 PST
Start showing profile data in the DataGrid of the ScriptTimelineView.
Comment 1 Radar WebKit Bug Importer 2014-01-30 02:35:51 PST
<rdar://problem/15944978>
Comment 2 Timothy Hatcher 2014-01-30 02:43:16 PST
Created attachment 222653 [details]
Patch
Comment 3 Timothy Hatcher 2014-01-30 02:46:44 PST
Created attachment 222654 [details]
Screenshot
Comment 4 Joseph Pecoraro 2014-01-30 11:44:20 PST
Comment on attachment 222653 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=222653&action=review

r=me

> Source/WebInspectorUI/ChangeLog:3
> +        Show profile data in the desecrate Scripts timeline view.

Typo: "desecrate"

> Source/WebInspectorUI/UserInterface/NavigationSidebarPanel.js:543
> +            // Keep all the elements at the same depth once the maximum is reached.
> +            childrenSubstring += i === maximumSidebarTreeDepth ? " .children" : " > .children";
> +            styleText += "." + WebInspector.NavigationSidebarPanel.ContentTreeOutlineElementStyleClassName + childrenSubstring + " > .item { ";

This must be some kind of a record for longest selector.

> Source/WebInspectorUI/UserInterface/ProfileNodeDataGridNode.js:35
> +    this._rangeEndTime = rangeEndTime || Infinity;

"0 || 0" is harmless, but  "0 || Infinity" could lead to a crazy accident. Maybe we should be a bit safer here?

> Source/WebInspectorUI/UserInterface/ScriptTimelineDataGridNode.js:33
> +    this._rangeEndTime = rangeEndTime || Infinity;

Ditto, 0 || Infinity.

> Source/WebInspectorUI/UserInterface/ScriptTimelineView.js:119
> +                dataGridNode = dataGridNode.traverseNextNode(false, null, true);

Gosh, these traverse functions need a better name to read at call sites. Same with that reveal function with a bunch of bools.

> Source/WebInspectorUI/UserInterface/TimelineDataGrid.js:274
> +        // Collect parent nodes htat need their children sorted. So this in two phases since

Typo: "htat"
Comment 5 Timothy Hatcher 2014-01-30 17:32:01 PST
https://trac.webkit.org/r163142