IDB: Rename "IDBTransactionIdentifier" to be more general purpose
The purpose of IDBTransactionIdentifier is to pair a DatabaseProcessIDBConnection with an integer ID for unique hashing.
Previously we only cared about transaction integer IDs but now we'll need to use for cursor integer IDs also.
My proposed rename is to "IDBIdentifier"
Created attachment 222371 [details]
This was incomplete. Since the type name no longer carries all the information, variable names will need to be updated as well.
Created attachment 222376 [details]
Patch take 2 (v1)
Followup landed in http://trac.webkit.org/changeset/162891