Bug 12761 - REGRESSION: Misspelled words cannot be corrected using context menu
Summary: REGRESSION: Misspelled words cannot be corrected using context menu
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh Intel OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://bugs.webkit.org
Keywords: Regression
: 12937 12955 13515 13562 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-02-13 08:27 PST by geoff kruse
Modified: 2007-06-24 12:15 PDT (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description geoff kruse 2007-02-13 08:27:37 PST
In the latest nightly, misspelled words are underlined correctly but right clicking on the word does not bring up the list of suggestions.

Steps to reproduce:

1) In the Comments Text Area in Bugzilla type "this is badd"
2) Right click on "badd"

In the current version of Safari you get a long list of suggestions for how to spell badd correctly.  In the current version of webkit you do not.  This could possibly be related to http://bugs.webkit.org/show_bug.cgi?id=11040 but I see it on any editable text area, not just gmail.  Entering new bug as advised by mitzpettel on #webkit
Comment 1 mitz 2007-02-13 10:29:10 PST
Spelling guesses are not the only items missing from the context menu. Cut and Paste are also missing, for example.
Comment 2 Darin Adler 2007-02-16 08:08:48 PST
This might be because of mismatch between Safari version and WebKit version.
Comment 3 John Sullivan 2007-02-16 08:43:53 PST
Yes, this is fallout from changes to make context menus compatible with other clients. Tiger Safari running on TOT WebKit will never show the editing-related context menu items.

We do not intend to fix this explicitly, but the problem will go away when a newer Safari is released.

I should add this to the known incompatibilities wiki page at <http://trac.webkit.org/projects/webkit/wiki/Known%20incompatibilities%20between%20open-source%20WebKit%20and%20Safari>. Currently I can't figure out how to log into that wiki in order to edit it though.
Comment 4 David Kilzer (:ddkilzer) 2007-02-16 09:04:55 PST
(In reply to comment #3)
> I should add this to the known incompatibilities wiki page at
> <http://trac.webkit.org/projects/webkit/wiki/Known%20incompatibilities%20between%20open-source%20WebKit%20and%20Safari>.

I added a blurb.

> Currently I can't figure out how to log into that wiki in order to edit it
> though.

I think the wiki is yet another separate username/password combination.  You may have to register to make changes.

Comment 5 John Sullivan 2007-02-16 09:20:31 PST
Thanks David!
Comment 6 David Kilzer (:ddkilzer) 2007-03-02 06:34:29 PST
*** Bug 12937 has been marked as a duplicate of this bug. ***
Comment 7 mitz 2007-03-03 10:45:26 PST
*** Bug 12955 has been marked as a duplicate of this bug. ***
Comment 8 Matt Lilek 2007-04-26 19:21:31 PDT
*** Bug 13515 has been marked as a duplicate of this bug. ***
Comment 9 David Kilzer (:ddkilzer) 2007-05-01 08:53:45 PDT
*** Bug 13562 has been marked as a duplicate of this bug. ***