Needed for InspectorDebuggerAgent (e.g. setting breakpoints, stepping through source code, evaluating JavaScript on call frames). This is a non-tivial move. It makes these changes: - Move JavaScriptCallFrame from being idl generated to native JS. - Make some minor changes to ScriptDebugServer so that it doesn't rely on WebCore knowledge.
Created attachment 222171 [details] [PATCH] Part 1 - JavaScriptCallFrame
Created attachment 222172 [details] [PATCH] Part 2 - ScriptDebugServer
Created attachment 222173 [details] [PATCH] For Bots 1
Attachment 222171 [details] did not pass style-queue: ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:76: GLOBAL_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:77: LOCAL_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:78: WITH_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:79: CLOSURE_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:80: CATCH_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 5 in 15 files If any of these errors are false positives, please file a bug against check-webkit-style.
Attachment 222173 [details] did not pass style-queue: ERROR: Source/JavaScriptCore/inspector/ScriptDebugServer.h:89: The parameter name "callback" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:76: GLOBAL_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:77: LOCAL_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:78: WITH_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:79: CLOSURE_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:80: CATCH_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 6 in 32 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 222171 [details] [PATCH] Part 1 - JavaScriptCallFrame r=me
Comment on attachment 222172 [details] [PATCH] Part 2 - ScriptDebugServer r=me
Comment on attachment 222171 [details] [PATCH] Part 1 - JavaScriptCallFrame View in context: https://bugs.webkit.org/attachment.cgi?id=222171&action=review > Source/JavaScriptCore/inspector/JSJavaScriptCallFramePrototype.cpp:66 > +#define JSC_NATIVE_NON_INDEX_ACCESSOR(jsName, cppName, attributes) \ Any reason this can't be an inline function?
(In reply to comment #8) > (From update of attachment 222171 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=222171&action=review > > > Source/JavaScriptCore/inspector/JSJavaScriptCallFramePrototype.cpp:66 > > +#define JSC_NATIVE_NON_INDEX_ACCESSOR(jsName, cppName, attributes) \ > > Any reason this can't be an inline function? This, like the other JSC_NATIVE* macros, assumes you have "exec, globalObject, and vm" variables in scope with those names. So turning this into inline function would double the number of arguments to JSC_NATIVE_NON_INDEX_ACCESSOR making it a bit harder to read. However, it would get rid of the need for the anonymous scope in the macro. I like the easier to read call site matching JSC_NATIVE_FUNCTION. Would an inline function be preferred?
Created attachment 222185 [details] [PATCH] For Bots 2 Apparently includes between debug and release are different! Adding some needed for Release builds.
Attachment 222185 [details] did not pass style-queue: ERROR: Source/JavaScriptCore/inspector/ScriptDebugServer.h:89: The parameter name "callback" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:76: GLOBAL_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:77: LOCAL_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:78: WITH_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:79: CLOSURE_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:80: CATCH_SCOPE is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 6 in 32 files If any of these errors are false positives, please file a bug against check-webkit-style.
Landed <http://trac.webkit.org/changeset/162757>.