Bug 127441 - Image in SVG disappears when displayed via HTML img
Summary: Image in SVG disappears when displayed via HTML img
Status: RESOLVED DUPLICATE of bug 99677
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.9
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-22 12:26 PST by Alex Milowski
Modified: 2015-05-11 10:40 PDT (History)
4 users (show)

See Also:


Attachments
The SVG Image (21.41 KB, image/svg+xml)
2014-01-22 12:26 PST, Alex Milowski
no flags Details
The test HTML file that shows the issue. (148 bytes, application/xhtml+xml)
2014-01-22 12:27 PST, Alex Milowski
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Milowski 2014-01-22 12:26:55 PST
Created attachment 221889 [details]
The SVG Image

When the SVG is view directly by the browser, it displays correctly.  When it is displayed via an HTML img element, the image within the SVG disappears.
Comment 1 Alex Milowski 2014-01-22 12:27:39 PST
Created attachment 221890 [details]
The test HTML file that shows the issue.
Comment 2 Alex Milowski 2014-01-22 12:29:37 PST
Additional testing shows that it doesn't work properly in Safari Version 7.0.1 (9537.73.11) but does in Chrome Version 32.0.1700.77 ... although that has forked from WebKit now.
Comment 3 Thaddee Tyl 2015-05-10 05:41:13 PDT
Updated external test case: https://thefiletree.com/gh-badges/button.html?plug=none

As shown, having the <image> in an SVG works inline, in embed, in object, in iframe, but not in an <img>.
Comment 4 Said Abou-Hallawa 2015-05-11 10:40:26 PDT
Only data uri images are allowed as sub-resources in SVGs.

*** This bug has been marked as a duplicate of bug 99677 ***