Bug 127411 - fast/dom/Window/alert-undefined.html is flaky on bots because of accessibility
Summary: fast/dom/Window/alert-undefined.html is flaky on bots because of accessibility
Status: RESOLVED DUPLICATE of bug 127439
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks: 126021
  Show dependency treegraph
 
Reported: 2014-01-21 23:58 PST by Alexey Proskuryakov
Modified: 2014-01-26 15:38 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2014-01-21 23:58:42 PST
fast/dom/Window/alert-undefined.html freezes when run after accessibility tests, presumably because of SpinRunLoopWhileWaitingForReply.

This happens on bots in practice, causing flakiness.

To reproduce,

run-webkit-tests -2 accessibility/spinbutton-value.html fast/dom/Window/alert-undefined.html -v --child-processes=1
Comment 1 Radar WebKit Bug Importer 2014-01-21 23:58:55 PST
<rdar://problem/15878428>
Comment 2 chris fleizach 2014-01-26 15:38:12 PST

*** This bug has been marked as a duplicate of bug 127439 ***