Bug 127403 - Add a minimalistic SPI to control the layout size outside of WKView
Summary: Add a minimalistic SPI to control the layout size outside of WKView
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Benjamin Poulain
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-21 20:58 PST by Benjamin Poulain
Modified: 2014-01-22 21:01 PST (History)
2 users (show)

See Also:


Attachments
Patch (3.73 KB, patch)
2014-01-21 21:01 PST, Benjamin Poulain
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Poulain 2014-01-21 20:58:39 PST
Add a minimalistic SPI to control the layout size outside of WKView
Comment 1 Benjamin Poulain 2014-01-21 21:01:14 PST
Created attachment 221826 [details]
Patch
Comment 2 Ian Henderson 2014-01-21 21:04:16 PST
Comment on attachment 221826 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=221826&action=review

Looks good to me either way.

> Source/WebKit2/UIProcess/API/Cocoa/WKViewPrivate.h:45
> +- (void)overrideMinimumLayoutSize:(CGSize)forcedSize;

Might this work better as a property?  E.g.

@property (nonatomic) CGSize minimumLayoutSizeOverride;
Comment 3 Ian Henderson 2014-01-21 21:04:43 PST
(In reply to comment #2)
> (From update of attachment 221826 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=221826&action=review
> 
> Looks good to me either way.
> 
> > Source/WebKit2/UIProcess/API/Cocoa/WKViewPrivate.h:45
> > +- (void)overrideMinimumLayoutSize:(CGSize)forcedSize;
> 
> Might this work better as a property?  E.g.
> 
> @property (nonatomic) CGSize minimumLayoutSizeOverride;

The "looks good to me either way" was meant to be after that comment…
Comment 4 Sam Weinig 2014-01-21 21:25:02 PST
Comment on attachment 221826 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=221826&action=review

>>> Source/WebKit2/UIProcess/API/Cocoa/WKViewPrivate.h:45
>>> +- (void)overrideMinimumLayoutSize:(CGSize)forcedSize;
>> 
>> Might this work better as a property?  E.g.
>> 
>> @property (nonatomic) CGSize minimumLayoutSizeOverride;
> 
> The "looks good to me either way" was meant to be after that comment…

I agree, a property might be better. r=me.
Comment 5 Benjamin Poulain 2014-01-22 21:01:00 PST
Committed r162590: <http://trac.webkit.org/changeset/162590>