Bug 127396 - WebKit2 View Gestures (Swipe): Give WebCore the first crack at scroll events if it needs it
Summary: WebKit2 View Gestures (Swipe): Give WebCore the first crack at scroll events ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Tim Horton
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-01-21 18:23 PST by Tim Horton
Modified: 2014-01-28 16:46 PST (History)
5 users (show)

See Also:


Attachments
patch (14.97 KB, patch)
2014-01-28 15:06 PST, Tim Horton
no flags Details | Formatted Diff | Diff
patch (15.13 KB, patch)
2014-01-28 15:17 PST, Tim Horton
no flags Details | Formatted Diff | Diff
use NSEvent at the WKView level (15.15 KB, patch)
2014-01-28 15:33 PST, Tim Horton
no flags Details | Formatted Diff | Diff
remove unneeded fwd declaration (14.95 KB, patch)
2014-01-28 15:35 PST, Tim Horton
andersca: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Horton 2014-01-21 18:23:04 PST
If a page has synchronous wheel event handlers, we should let it attempt to handle events before starting a swipe.
Comment 1 Radar WebKit Bug Importer 2014-01-21 18:23:19 PST
<rdar://problem/15876893>
Comment 2 Tim Horton 2014-01-28 15:06:45 PST
Created attachment 222501 [details]
patch
Comment 3 Simon Fraser (smfr) 2014-01-28 15:08:43 PST
Comment on attachment 222501 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=222501&action=review

> Source/WebKit2/UIProcess/API/mac/PageClientImpl.h:118
> +    virtual void didNotHandleWheelEvent(const NativeWebWheelEvent&) override;

Who did not handle it? The receiver (the page client)?
Comment 4 WebKit Commit Bot 2014-01-28 15:09:53 PST
Attachment 222501 [details] did not pass style-queue:


ERROR: Source/WebKit2/UIProcess/mac/ViewGestureController.h:59:  The parameter name "event" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 1 in 11 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Tim Horton 2014-01-28 15:17:25 PST
Created attachment 222504 [details]
patch
Comment 6 Tim Horton 2014-01-28 15:33:11 PST
Created attachment 222510 [details]
use NSEvent at the WKView level
Comment 7 Tim Horton 2014-01-28 15:35:05 PST
Created attachment 222513 [details]
remove unneeded fwd declaration
Comment 8 Anders Carlsson 2014-01-28 16:30:22 PST
Comment on attachment 222513 [details]
remove unneeded fwd declaration

View in context: https://bugs.webkit.org/attachment.cgi?id=222513&action=review

> Source/WebKit2/UIProcess/mac/ViewGestureController.h:114
> +    bool m_hasDeferredSwipe;
> +    SwipeDirection m_deferredSwipeDirection;

I think pending would be more fitting than deferred here.
Comment 9 Tim Horton 2014-01-28 16:46:39 PST
http://trac.webkit.org/changeset/162984