Bug 12694 - REGRESSION: The whole page gets HREF from a point
Summary: REGRESSION: The whole page gets HREF from a point
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.pomcast.com/wp/?lp_lang_pr...
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2007-02-08 05:23 PST by StuFF mc
Modified: 2008-02-10 14:49 PST (History)
2 users (show)

See Also:


Attachments
Screenshot (46.87 KB, image/jpeg)
2007-02-08 09:48 PST, StuFF mc
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description StuFF mc 2007-02-08 05:23:38 PST
For a reason I can't understand, starting at "Le StuFF chez la grenouille !" the whole page is in the HREF, as a link :( No problem with current Safari or Firefox...
Comment 1 Alexey Proskuryakov 2007-02-08 09:34:46 PST
If reproducible, this would be P1 (Regression), but I cannot reproduce.
Comment 2 StuFF mc 2007-02-08 09:48:33 PST
Created attachment 13059 [details]
Screenshot

This is what I see in the specified version of WebKit. Starting at "Le StuFF chez la grenouille" the whole HTML is considered an hyperlink...
Comment 3 StuFF mc 2007-02-08 09:49:52 PST
Please check out http://www.pomcast.com/wp/?lp_lang_pref=fr , with WebKit 419.3 where you can see it...
Comment 4 StuFF mc 2007-02-08 09:52:57 PST
(In reply to comment #1)
> If reproducible, this would be P1 (Regression), but I cannot reproduce.
> 

Sorry just understood WebKit is v420+, where this problem occurs, not in 419.x (stable Safari)
Comment 5 Sam Weinig 2007-02-08 10:13:40 PST
I am not able to reproduce this. Is anyone able to confirm this is still happening? 
Comment 6 David Kilzer (:ddkilzer) 2007-02-08 12:08:16 PST
(In reply to comment #5)
> I am not able to reproduce this. Is anyone able to confirm this is still
> happening? 

I do not see this with a local debug build of WebKit r19497 with Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8N1037).
Comment 7 StuFF mc 2007-02-08 12:14:33 PST
I repeat: The problem is not on 419.3, but well on the Nightly... 420+
Comment 8 David Kilzer (:ddkilzer) 2007-02-08 12:26:47 PST
(In reply to comment #7)
> I repeat: The problem is not on 419.3, but well on the Nightly... 420+

StuFF mc, could you save a webarchive of the page when it does this?  Does it happen every time you load the page, or only sometimes?

I do see a long pause before the content in the center is loaded; I wonder if this could be a timing issue with the HTML parser?

Comment 9 David Kilzer (:ddkilzer) 2007-02-08 12:33:16 PST
(In reply to comment #7)
> I repeat: The problem is not on 419.3, but well on the Nightly... 420+

BTW, the number in parenthesis in "Safari 2.0.4 (419.3)" is the *Safari* build number, not WebKit's build number.  To see the version of WebKit that is used by each version of Safari, see this web page:

http://developer.apple.com/internet/safari/uamatrix.html

Comment 10 Mark Rowe (bdash) 2007-02-13 17:50:46 PST
I cannot reproduce this with ToT WebKit either.
Comment 11 Mark Rowe (bdash) 2007-02-13 18:29:28 PST
Given that this is currently not reproducible I see no reason for this to be a P1.
Comment 12 Robert Blaut 2008-02-10 14:49:40 PST
I've tested the page http://www.pomcast.com/wp/?lp_lang_pref=en&p=693 with the latest Webkit r30123 and I cannot confirm this bug. So WORKSFORME. 

Feel free to reopen the bug if you still experience the problem.