Bug 126934 - srcset renders 2x images at 2x width and height
Summary: srcset renders 2x images at 2x width and height
Status: RESOLVED DUPLICATE of bug 123832
Alias: None
Product: WebKit
Classification: Unclassified
Component: Images (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dean Jackson
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-01-13 14:56 PST by Vicki Pfau
Modified: 2014-01-29 13:47 PST (History)
2 users (show)

See Also:


Attachments
Repro (11.62 KB, application/zip)
2014-01-13 14:56 PST, Vicki Pfau
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vicki Pfau 2014-01-13 14:56:17 PST
Created attachment 221081 [details]
Repro

While testing srcset out on a 100x100px image with a 2x image, I discovered that in the nightlies, the 2x image is rendered 2x the width and height instead of the same width and height but with 2x density. A simple repro is attached.
Comment 1 Theresa O'Connor 2014-01-13 16:38:33 PST
The intrinsic size of the image should be adjusted based on the candidate's Nx value. This is clear in the WHATWG spec, but is not currently clear in the W3C one. (It will become clear when I next pull in the relevant WHATWG changes.)
Comment 2 Radar WebKit Bug Importer 2014-01-14 15:59:54 PST
<rdar://problem/15819696>
Comment 3 Theresa O'Connor 2014-01-29 13:47:14 PST

*** This bug has been marked as a duplicate of bug 123832 ***