Bug 12692 - Assertion failure in editing context menu code
Summary: Assertion failure in editing context menu code
Status: RESOLVED DUPLICATE of bug 12688
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2007-02-08 00:33 PST by Beth Dakin
Modified: 2007-02-08 00:43 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Beth Dakin 2007-02-08 00:33:19 PST
radar: 4983949

We are hitting the ASSERT_NOT_REACHED() at the end of fixMenusReceivedFromOldClients() every time we try to bring up and editing context menu in TOT. We are hitting the assert because all of the comparisons are failing. It should be sufficient to compare addresses since UI_STRING *should* return the same exact string every time, but for some reason, our menu titles, though identical in content, are not identical in address to the strings being generated by UI_STRING. 

One possible solution is to do a real string comparison, but this should not be necessary. Did something change to UI_STRING recently so that we do not always return the same exact string?

But! If I call UI_STRING twice in a row inside fixMenusReceivedFromOldClients(), it does return the same *exact* string twice.
Comment 1 Adam Roben (:aroben) 2007-02-08 00:43:56 PST

*** This bug has been marked as a duplicate of 12688 ***