Bug 126791 - Web Inspector: CallFrame is missing saveIdentityToCookie, or should be excluded
Summary: Web Inspector: CallFrame is missing saveIdentityToCookie, or should be excluded
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Brian Burg
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-01-10 16:27 PST by Joseph Pecoraro
Modified: 2014-01-16 13:19 PST (History)
6 users (show)

See Also:


Attachments
patch (1.50 KB, patch)
2014-01-16 10:06 PST, Brian Burg
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Pecoraro 2014-01-10 16:27:04 PST
file:///Volumes/Data/Build/Debug/WebInspectorUI.framework/Resources/NavigationSidebarPanel.js:213: CONSOLE ERROR: Error: TreeElement.representedObject is missing a saveIdentityToCookie implementation.

WebInspector.CallFrameTreeElement => WebInspector.CallFrame
Comment 1 Joseph Pecoraro 2014-01-10 16:28:09 PST
STEPS TO REPRODUCE:
1. Inspect a page
2. Set a breakpoint
3. Trigger breakpoint.
4. Select a CallFrame tree element in the debugger sidebar
5. Close inspector
  => exception seen in console
Comment 2 Radar WebKit Bug Importer 2014-01-10 16:28:22 PST
<rdar://problem/15797412>
Comment 3 Radar WebKit Bug Importer 2014-01-10 16:28:26 PST
<rdar://problem/15797403>
Comment 4 Brian Burg 2014-01-10 16:30:33 PST
This should ignore call frame elements, since (currently) we continue and remove all breakpoints when the inspector is closed.
Comment 5 Brian Burg 2014-01-16 10:06:18 PST
Created attachment 221388 [details]
patch
Comment 6 WebKit Commit Bot 2014-01-16 13:19:13 PST
Comment on attachment 221388 [details]
patch

Clearing flags on attachment: 221388

Committed r162144: <http://trac.webkit.org/changeset/162144>
Comment 7 WebKit Commit Bot 2014-01-16 13:19:15 PST
All reviewed patches have been landed.  Closing bug.