Bug 12677 - REGRESSION: Return key is always sent when you confirm a clause in kotoeri.
Summary: REGRESSION: Return key is always sent when you confirm a clause in kotoeri.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Adele Peterson
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-02-06 23:42 PST by Maciej Stachowiak
Modified: 2007-03-07 15:07 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Stachowiak 2007-02-06 23:42:11 PST
2006-10-01 21:58:21 Masayuki Shibatani:
* SUMMARY
- Return key is always sent when you want to confirm a clause if you still have any un-confirmed clauses.

- The symptom can be observed on both of new Kotoeri (IMK) and old Kotoeri (component) on Leopard 9A274. However the symptom isn't observed on London (8J134).

* STEPS TO REPRODUCE
1. Open a web page https://support.microsoft.com/common/survey.aspx?scid=sw;ja;1238&showpage=1&ws=japan by Safari.
2. Click at '件名'.
3. Type "FAQに記載された、Windows XPの" like something. When you type these words, you need to hit return key several times.

* RESULTS
Actual: The page has been submitted and jumps to next page when you type return key even if you still need to continue type while you didn't confirm several clauses.


2006-10-01 22:02:04 Masayuki Shibatani:
Expected: It should be just confirm one clauses and shouldn't send return key when you still have un-confirmed clauses.

2006-12-04 01:56:37 Michi Iwasaki:
"https://support.microsoft.com/common/survey.aspx?scid=sw;ja;1238&showpage=1&ws=japan"

2006-10-01 22:08:40 Masayuki Shibatani:
I haven't seen the typical symptom on the other web pages like mixi's diary on same environment. I guess it could be a specific problem on above web page.

2006-10-03 18:10:33 Yasuo Kida:
Wow. Confirmed the problem. The page is unusable. similar to <rdar://problem/4753259> "regression: Can't enter Japanese text w/ Gmail" in that the web page is stealing the key events before the input method gets them.

2006-10-03 18:17:58 Yasuo Kida:
At the step 3, you do not need to type such a complex text. Just type "aaa" you'll see "あああ" with underline. Try confirming the text by typing a return key. => voila!

This is a definite blocker.

2006-12-04 01:54:08 Michi Iwasaki:
This occurs also with Component IMs such as EGBRIDGE.

2006-12-04 01:58:42 Michi Iwasaki:
and Component Kotoeri on Leopard.

2006-12-04 01:58:58 Michi Iwasaki:
However, it doesn't occur on Tiger.

2006-12-04 02:04:16 Michi Iwasaki:
I guess the cause is an under layer change on Leopard.  WebView or TSM?

2006-12-04 02:06:13 Michi Iwasaki:
Could you please look into this from WebCore side?

2006-12-11 13:59:22 Stephanie Lewis:
Safari BRB Reviewed

2007-01-15 14:17:39 Alice Liu:
Safari blocker reviewed

<rdar://problem/4759563>
Comment 1 Alexey Proskuryakov 2007-02-10 11:01:46 PST
See also: bug 10010 / <rdar://4822935>.
Comment 2 Darin Adler 2007-02-10 22:32:22 PST
Got a fix.
Comment 3 Darin Adler 2007-02-12 11:22:20 PST
Committed revision 19579.
Comment 4 Darin Adler 2007-02-27 05:24:55 PST
Turns out this is not yet fixed.
Comment 5 Darin Adler 2007-02-27 05:25:43 PST
I mistakenly thought this was about the default form submission with return, which was fixed. But I believe it's actually about keypress events, which are still being sent.
Comment 6 Adele Peterson 2007-03-07 15:07:47 PST
Committed revision 20030.