Bug 126696 - DocumentOrderedMap should use iterator
Summary: DocumentOrderedMap should use iterator
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-09 07:38 PST by Antti Koivisto
Modified: 2014-01-09 12:18 PST (History)
5 users (show)

See Also:


Attachments
patch (4.21 KB, patch)
2014-01-09 07:52 PST, Antti Koivisto
no flags Details | Formatted Diff | Diff
better patch (7.82 KB, patch)
2014-01-09 08:15 PST, Antti Koivisto
kling: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antti Koivisto 2014-01-09 07:38:38 PST
Instead of ElementTraversal
Comment 1 Antti Koivisto 2014-01-09 07:52:26 PST
Created attachment 220734 [details]
patch
Comment 2 Antti Koivisto 2014-01-09 08:15:08 PST
Created attachment 220738 [details]
better patch
Comment 3 Andreas Kling 2014-01-09 08:48:35 PST
Comment on attachment 220738 [details]
better patch

View in context: https://bugs.webkit.org/attachment.cgi?id=220738&action=review

> Source/WebCore/dom/DocumentOrderedMap.cpp:213
> +        auto elementDescandants = descendantsOfType<Element>(*scope.rootNode());

Typo, descandants.

> Source/WebCore/dom/DocumentOrderedMap.cpp:214
> +        auto it = entry.element ? elementDescandants.find(*entry.element) : elementDescandants.begin();

We need a better name for find(). beginAt()?
Comment 4 Antti Koivisto 2014-01-09 12:18:26 PST
https://trac.webkit.org/r161572