RESOLVED FIXED 126508
[EFL] Merge ewk_view_single into ewk_view
https://bugs.webkit.org/show_bug.cgi?id=126508
Summary [EFL] Merge ewk_view_single into ewk_view
Ryuan Choi
Reported 2014-01-05 17:03:01 PST
Since ewk_view_tiled is removed, we don't need to keep ewk_view_single.cpp out of ewk_view_single.cpp It just makes extra hierarchy(ewk_base and ewk_single)
Attachments
Patch (32.76 KB, patch)
2014-01-05 17:09 PST, Ryuan Choi
no flags
Patch (34.98 KB, patch)
2014-01-05 17:16 PST, Ryuan Choi
no flags
Patch (34.79 KB, patch)
2014-01-05 17:21 PST, Ryuan Choi
no flags
Patch (38.66 KB, patch)
2014-01-07 22:06 PST, Ryuan Choi
no flags
Patch (38.60 KB, patch)
2014-01-08 01:08 PST, Ryuan Choi
no flags
Ryuan Choi
Comment 1 2014-01-05 17:09:24 PST
Ryuan Choi
Comment 2 2014-01-05 17:16:05 PST
Ryuan Choi
Comment 3 2014-01-05 17:21:48 PST
Gyuyoung Kim
Comment 4 2014-01-07 20:19:35 PST
Comment on attachment 220410 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=220410&action=review > Source/WebKit/efl/ewk/ewk_view.cpp:1014 > + Evas_Coord x, y, cw, ch; How about using more meaningful name for cw, ch ? centerWidth, centerHeight ? > Source/WebKit/efl/ewk/ewk_view.cpp:1049 > + startHeight = startHeight + moveLineUpDown; I wonder why we need this line. > Source/WebKit/efl/ewk/ewk_view.cpp:1135 > + return true; I doubt if "return true" is correct logic. > Source/WebKit/efl/ewk/ewk_view.cpp:1147 > + if (smartData->animated_zoom.zoom.current < 0.00001) { How about use a constant variable for 0.00001 ? > Source/WebKit/efl/ewk/ewk_view.cpp:1404 > + // TODO: review Need to re-write with more detail comment. > Source/WebKit/efl/ewk/ewk_view.cpp:1408 > + Evas_Coord dx, dy, cw, ch; ditto. > Source/WebKit/efl/ewk/ewk_view.cpp:1442 > +} Add a new line.
Ryuan Choi
Comment 5 2014-01-07 22:06:44 PST
Ryuan Choi
Comment 6 2014-01-08 01:08:50 PST
Ryuan Choi
Comment 7 2014-01-08 01:12:15 PST
Comment on attachment 220410 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=220410&action=review >> Source/WebKit/efl/ewk/ewk_view.cpp:1014 >> + Evas_Coord x, y, cw, ch; > > How about using more meaningful name for cw, ch ? centerWidth, centerHeight ? Ok, I changed to contentWidth, contentHeight. >> Source/WebKit/efl/ewk/ewk_view.cpp:1049 >> + startHeight = startHeight + moveLineUpDown; > > I wonder why we need this line. It's rquired. But I refactored little bit. s/startHeight/row and moved into for loop. >> Source/WebKit/efl/ewk/ewk_view.cpp:1135 >> + return true; > > I doubt if "return true" is correct logic. You're right. scrolls_process doesn't need to return anything. I fixed it. >> Source/WebKit/efl/ewk/ewk_view.cpp:1147 >> + if (smartData->animated_zoom.zoom.current < 0.00001) { > > How about use a constant variable for 0.00001 ? It's for epsilon. I changed to std::numeric_limits<float>::epsilon() >> Source/WebKit/efl/ewk/ewk_view.cpp:1404 >> + // TODO: review > > Need to re-write with more detail comment. It looks wrong comment. removed >> Source/WebKit/efl/ewk/ewk_view.cpp:1408 >> + Evas_Coord dx, dy, cw, ch; > > ditto. fixed >> Source/WebKit/efl/ewk/ewk_view.cpp:1442 >> +} > > Add a new line. Ooops. done
Gyuyoung Kim
Comment 8 2014-01-08 15:52:30 PST
Comment on attachment 220607 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=220607&action=review Looks fine. > Source/WebKit/efl/ewk/ewk_view.cpp:1415 > + Evas_Coord dx, dy, contentWidth, contentHeight; It would be nicer if we use more readable name for dx, dy.
Ryuan Choi
Comment 9 2014-01-08 16:55:34 PST
Ryuan Choi
Comment 10 2014-01-08 16:56:05 PST
Comment on attachment 220607 [details] Patch Clearing flags. Landed manually after applied last comment.
Note You need to log in before you can comment on or make changes to this bug.