Bug 126505 - [CMake] [GTK] Fix the build for the WebKitGTK+ developer configuration
Summary: [CMake] [GTK] Fix the build for the WebKitGTK+ developer configuration
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Martin Robinson
URL:
Keywords:
Depends on:
Blocks: 126212
  Show dependency treegraph
 
Reported: 2014-01-05 14:11 PST by Martin Robinson
Modified: 2014-01-06 10:29 PST (History)
5 users (show)

See Also:


Attachments
Patch (20.75 KB, patch)
2014-01-05 14:25 PST, Martin Robinson
gns: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Robinson 2014-01-05 14:11:44 PST
build-webkit enables some features that haven't previously been enabled for the CMake build. This reveals a lot of missing files and IDLs in the IDL list, as well as some dependencies we are not pulling in. This bug tracks fixing all the build breaks caused by building with build-webkit.
Comment 1 Martin Robinson 2014-01-05 14:25:25 PST
Created attachment 220401 [details]
Patch
Comment 2 Martin Robinson 2014-01-06 10:29:21 PST
Committed r161351: <http://trac.webkit.org/changeset/161351>